PfSense Cannot Get WAN DHCP IP Address



  • Hi, I read on this topic a few times.  My situation is that my WAN interface cannot get an IP from the cable modem.  There are two scenarios:

    1. The WAN displays 0.0.0.0

    2. The WAN displays 68.10.70.1 (for example).  This is the router address for my ISP.  The correct IP should be 68.10.70.113.  I found the 68.10.70.113 in the System Logs but somehow it has not been set to the IP address.

    I called the ISP and they said it should be no problem switching routers.

    In reference:

    • My E3000 router would pick up the ISP IP immediately (I've tried unplugging modem and the etc)
    • If I plug the pfSense router into the E3000's LAN port, pfSense will pick up an IP address right away and all will be happy.

    The ethernet port on the pfSense has two LEDs (right and left).  When I connect to the E3000 (picking up IP), both LEDs will be flashing.  When connecting to the cable modem, only one LED will be lid.

    Additional Info:  The pfSense in on Exsi with one physical nic.  The WAN traffic is VLAN into a managed switch.

    When I plug pfSense into the E3000, everything works - all my devices are getting DHCP LAN ip addresses and they all go to the Internet happily.

    What might be the issue of the WAN DHCP?



  • Could you clarify what you mean when you say "Additional Info:  The pfSense in on Exsi with one physical nic.  The WAN traffic is VLAN into a managed switch."

    Do you mean that the WAN is connected to the cable modem through a managed switched on a VLAN?

    If that is the case, have you set a VLAN interface up with the approproate tag or are you trying to use the raw interface without tagging it?
    e.g. WAN is on em0 or VLAN xxx on em0?



  • Sorry for the bad wording.

    cable modem - managed switch - pfSense

    cable modem to port 8 on the managed switch (Untagged) pfSense is on port 7 (Tagged)

    Port 8 traffic will be VLAN (with pvid) into port 7.  pfSense does not know the VLAN.  They are managed by Exsi.  So on the em0 it's a "physical" mac.

    @mitchtay:

    Could you clarify what you mean when you say "Additional Info:  The pfSense in on Exsi with one physical nic.  The WAN traffic is VLAN into a managed switch."

    Do you mean that the WAN is connected to the cable modem through a managed switched on a VLAN?

    If that is the case, have you set a VLAN interface up with the approproate tag or are you trying to use the raw interface without tagging it?
    e.g. WAN is on em0 or VLAN xxx on em0?



  • I found the issue.  The ISP said they only allow one IP address and the first device MAC cable model sees will assign an IP.  So the managed switch (GS108T) gets an IP and the router behind it won't have the IP.

    Are there protocols I can disable on the port dedicated to cable modem so the cable modem won't see the MAC address?



  • May I ask why you're going from the cable modem to the switch? It would make a lot more sense to go from your cable modem straight to your WAN interface on pfSense.

    Either way, you should set a static management address on your GS108T. It shouldn't be set to DHCP in your scenario.



  • Because everything is virtual on pfSense.  The WAN and LAN are virtual nics.  They shared the same physical line into the switch.  My physical machine only has one ethernet.

    I made it work.  I disabled the LLDP on the "WAN" port on the GS108T.  Now pfSense has been working since.  I also have Security Onion running on the same physical machine.  SO sees all the traffic and my focus has been shifted to all IDS alerts.

    @timthetortoise:

    May I ask why you're going from the cable modem to the switch? It would make a lot more sense to go from your cable modem straight to your WAN interface on pfSense.

    Either way, you should set a static management address on your GS108T. It shouldn't be set to DHCP in your scenario.



  • I fail to see how LLDP would have anything to do with your switch grabbing a DHCP IP for its management address, but alright.