Squid has never worked



  • Depending on how much time off I have, I've played with squid more than a few times.  squid, squid3, the development versions…. I've installed and removed each package about a half dozen times, each.  None has worked for me, ever.

    Most recently, I installed squid3, life was good for about a week.  Then I started noticing images would take a long time to load.  Then flash stopped working (couldn't see any pics of newegg products, etc).  Then I'd log into pfsense and I'd get a text only version, no graphics.  Finally, 99% of websites would simply fail to load.

    I managed to get the web configurator restarted via shell, got graphics for a sec, and removed the squid package altogether (again).  Couldn't remove the package from the text-only web configurator, and running "pkg_info" from the shell prompt listed two libraries, and that's it.

    So now the network appears to be working again, for now, only without my proxy.  I had grand ideas of running squid with squidgaurd to protect the kiddos at my house, and have never been able to get it to work.

    I'm on the latest release.

    Any ideas?


  • Banned

    Running out of disk or memory??



  • Did you followed squid3-dev forum posts to get it working?

    I have some squid boxes working fine.



  • @marcelloc:

    Did you followed squid3-dev forum posts to get it working?

    I have some squid boxes working fine.

    Can you post a link to the thread you are referencing?

    Disk usage is at 4% (60gb disk, 20gb was reserved for proxy) and memory is at 21% (4GB RAM).



  • https://forum.pfsense.org/index.php/topic,62256.0.html

    https://forum.pfsense.org/index.php?topic=66633.msg371406#msg371406

    @marcelloc:

    For amd64 you can use these cmd to fetch missing files

    fetch -o /usr/local/lib/libasn1.so.10 http://e-sac.siteseguro.ws/pfsense/8/amd64/All/ldd/libasn1.so.10
    fetch -o /usr/local/lib/libgssapi.so.10 http://e-sac.siteseguro.ws/pfsense/8/amd64/All/ldd/libgssapi.so.10
    fetch -o /usr/local/lib/libheimntlm.so.10 http://e-sac.siteseguro.ws/pfsense/8/amd64/All/ldd/libheimntlm.so.10
    fetch -o /usr/local/lib/libhx509.so.10 http://e-sac.siteseguro.ws/pfsense/8/amd64/All/ldd/libhx509.so.10
    fetch -o /usr/local/lib/libkrb5.so.10 http://e-sac.siteseguro.ws/pfsense/8/amd64/All/ldd/libkrb5.so.10
    fetch -o /usr/local/lib/libroken.so.10 http://e-sac.siteseguro.ws/pfsense/8/amd64/All/ldd/libroken.so.10