Gateway in 'Pending' status, lost connectivity through gateway



  • Hello,

    I have two internet connections, WAN as Tier 1 in my routing group, WAN2 as Tier 2, both set as static IPs.
    My WAN connection recently went down and I lost internet connectivity, WAN2 didn't come up.

    I was logging 'Gateways status could not be determined, considering all as up/active', and my Gateway Status WAN2 showed:

    
    Gateway		Monitor		RTT		Loss		Status 
    WANGW		x.x.x.x		53.4ms		0%		Online
    WAN2_GW		 <blank>Pending		Pending		Pending
    
    Monitor was blank on WAN2 even though I have a monitor IP configured.</blank> 
    

    Restarting the apinger service brought WAN2 back to an 'online' status.

    I am on an Alix board running 2.1p1-RELEASE (i386), built on Tue Nov 12 17:54:26 EST 2013, FreeBSD 8.3-RELEASE-p12.

    The p1 means this is a firmware from Netgate.

    I'm assuming upgrading to the latest firmware will resolve this?

    
    Apr 24 10:17:52       php: rc.newipsecdns: Gateways status could not be determined, considering all as up/active. (Group: InternetAccess)
    Apr 24 10:17:52	php: rc.newipsecdns: MONITOR: GW_WAN is down, removing from routing group InternetAccess
    Apr 24 10:17:52	php: rc.newipsecdns: Default gateway down setting WAN2GW as default!
    Apr 24 10:17:52	php: rc.newipsecdns: Gateways status could not be determined, considering all as up/active. (Group: InternetAccess)
    Apr 24 10:17:52	php: rc.newipsecdns: MONITOR: GW_WAN is down, removing from routing group InternetAccess
    Apr 24 10:17:51	php: rc.newipsecdns: Default gateway down setting WAN2GW as default!
    Apr 24 10:17:51	php: rc.newipsecdns: Gateways status could not be determined, considering all as up/active. (Group: InternetAccess)
    Apr 24 10:17:51	php: rc.newipsecdns: MONITOR: GW_WAN is down, removing from routing group InternetAccess
    Apr 24 10:17:51	php: rc.newipsecdns: Default gateway down setting WAN2GW as default!