Unbound 1.4.22 fails to install on pfSense 2.0.3-RELEASE (i386) with 404 error



  • I'm running pfSense 2.0.3-RELEASE (i386) that has no third party packages installed. I am in need of recursive DNS services. My intention was to install the Unbound package on the server. The package seen in the list of available packages is:  Alpha 1.4.22 platform: 2.0

    When choosing to install the Unbound package, the following happens in the package manager:

    Installation of Unbound FAILED!
    Beginning package installation for Unbound...
    Downloading package configuration file... done.
    Saving updated package information... done.
    Downloading Unbound and its dependencies... 
    Checking for package installation... 
     Downloading https://files.pfsense.org/packages/8/All/unbound-1.4.22.tbz ...  could not download from there or http://ftp2.FreeBSD.org/pub/FreeBSD/ports/i386/packages-8.1-release/All/unbound-1.4.22.tbz.
    of unbound-1.4.22 failed!
    
    Installation aborted.Backing up libraries... 
    Removing package...
    Starting package deletion for unbound-1.4.22...done.
    Starting package deletion for ldns-1.6.17...done.
    Starting package deletion for expat-2.1.0...done.
    Starting package deletion for libevent2-2.0.21...done.
    Removing Unbound components...
    Tabs items... done.
    Menu items... done.
    Services... done.
    Loading package instructions...
    Include file unbound.inc could not be found for inclusion.
    Deinstall commands... 
    Not executing custom deinstall hook because an include is missing.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    Cleaning up... Failed to install package.
    
    Installation halted.
    

    When attempting to curl or browse to the package at https://files.pfsense.org/packages/8/All/unbound-1.4.22.tbz or http://ftp2.FreeBSD.org/pub/FreeBSD/ports/i386/packages-8.1-release/All/unbound-1.4.22.tbz I receive page not found errors. I can't even find the 1.4.22 package anywhere in the hierarchy at http://ftp2.freebsd.org/pub/FreeBSD/ports/i386/ and the closest thing I can find on pfsenes.org's file server is https://files.pfsense.org/packages/8/All/unbound-1.4.22-i386.pbi

    Is there something I'm doing wrong?

    EDIT: Looks very similar to this issue: https://forum.pfsense.org/index.php/topic,73356.msg400535.html



  • I updated from pfSense 2.0.3 to pfSense 2.1.2 yesterday and attempted to install Unbound. It worked. Go figure.



  • Hrmm yeah only unbound-1.4.21_1.tbz is available. 1.4.22 for 2.0.X was not built for some reason automatically.
    You on 2.1.3 now so I am not going to worry too much :)