DHCPv6 Gateway Monitoring broken?



  • Is it just my (very minimal) test setup or is WAN_DHCP6 monitoring not working yet?
    I just set my WAN interface to DHCPv6 and it's working fine, but apinger.conf does only contain the IPv4 address. WAN_DHCP6 shows pending.
    I can ping6 with no problems and netstat -arn shows the correct default gateway (fe80::xxxx:xxxx:xxxx::de64). This is just DHCPv6 enabled on WAN (no IA_PD) behind an AVM FritzBox which terminates a SixXS tunnel. I'm on the lastest alpha build as of now.



  • Still no luck with
    2.2-ALPHA (amd64)
    built on Thu May 08 04:15:22 CDT 2014

    No one else having problems with WAN DHCPv6?


  • Rebel Alliance Developer Netgate

    It does appear to be broken but it seems to be not the monitor but the gateway in general. I get nothing in apinger.conf for the gateway, probably because there is nothing in /tmp/*_routerv6, and I have no default IPv6 route on the test box showing the issue.



  • Gateway monitoring even for static WANs is broken since 2.1.x. This is causing great trouble for multi-WAN gateway users.


  • Rebel Alliance Developer Netgate

    It works fine for me and many others on 2.1.3, but that is completely unrelated to this topic. This topic is not actually about a problem with apinger, but a problem with DHCPv6 and gateways in general. If you have more than anecdotal evidence that apinger is broken in certain configurations, start a new (relevant) thread with as much detail as possible.



  • Thought I'd mention I'm experiencing this as well. Have an ISP with native IPv6 through DHCPv6+PD… the WAN interface would get its address (it shows in the interface status page), but the LAN wouldn't, and the IPv6 gateway always showed as down. This happens whether I request a /64 or a /60 from my ISP.

    As another data point, this worked fine in the latest 2.1 release version on a different computer... I had to use the 2.2 alpha on my current system due to the new version of FreeBSD resolving a kernel panic issue with my new hardware.

    I was able to set up a GIF tunnel with static IPv6 on the LAN and it worked just fine, though. So it seems to be something about IPv6 and DHCP.

    EDIT: My issue was not related to this; I had a stray IPv6 tunnel gateway left from importing my 2.1.x config. After removing it, IPv6 with DHCP+PD from my ISP is working properly.