Siproxd and VoIP traffic shaping: no floating rules seems to correctly queue it



  • Hi,

    Have searched the forum only to find unanswered posts, or replies with more questions.

    I have a pfsense 2.1.2 multi wan setup with traffic shaping. Prior to setting up siproxd, VoIP traffic was correctly queued to the VoIP queue.

    After setting it, the VoIP queues sit empty, and no floating rule seems to put it back there…

    Does this have to do with the fact there's a  hidden rule redirecting all outbound traffic to 127.0.0.1:5060? Flotaing rules won't catch traffic originating from the loopback address???

    No fix for this?



  • Wow, i was just experiencing this very thing. I have had siproxd up for a couple of years now, and it has done its job. I nixed the hidden redirect rule in the siproxd rules "include" script (as I use 5070 for my phones and siproxd so that 5060 is open for them SIP provider I have on my end, while allowing the some remote Asterisk PBX extensions to be able to be registered to on the phones on my end along with my local Asterisk server (long story).

    So, i finally figured I might need to try traffic shaping as there's now more stuff going in/out on my end. So, I ran the LAN/multi-WAN wizard for HSFC after doing some speedtest.net tests with my Comcast. When I applied the rules and began monitoring the queues (esp qVOIP), I got NO hits on it. In the floating rules, I then modified the qVOIP to include 5070 and the siproxd RTP range I happen to be using (7070-7099), but still no gold.

    So, you aren't alone in seeing this. I've more poking around to do on this yet, but I thought I would ACK your pain. :)



  • Well, I enabled RTP debugging on siproxd and telnet'ed to the debug port. I tried an extension routed through siproxd. it was not routed to the qVOIP. But on the RTP debug, I noticed that the UDP port my Polycom 650 was originating with 2224. It hit me that the Polycom default UDP port for RDP was 2222 (from past experience). So, for grins, I rolled it up to 7070 (the starting port for siproxd on my end) and tried the call again. still nothing. But in further examination, I noticed that the destination UDP port that siproxd was using for my remote Asterisk server was 12478 (outside the siproxd specified range of 7070-7099). The originating port siproxd used was 7076 (within the range). Now, i have static ports set for outbound NAT. But, siproxd is side-stepping NAT, so I guess it negotiates with the remote, and the Asterisk server's range is 10000-20000. So, on a hunch, I expanded the floating qVOIP outbound rule to cover UDP 7070-20000. Damned if that didn't do the trick! Now, my SIP and RTP routed through through siproxd is being routed into qVOIP. I am going to keeping investigating it further, but this must be why it was not matching the qVOIP rule. FYI!


Log in to reply