NRPE2 | Icinga/nagios | check_load | Almost there



  • I'm configuring icinga to monitor my pfsense box with NRPE2. I think that I am very close to getting the first command to work - check_load.

    At the command line, I'm able to get the desired output on both pfsense and icinga server using:

    ./check_load -w "15,10,5" -c "30,25,20"

    Except:

    The service status information in icinga shows:

    CHECK_NRPE: Received 0 bytes from daemon. Check the remote server logs for error messages.

    When i check the system log on pfsense :

    nrpe[4832]: Error: Request contained command arguments, but argument option is not enabled!
    nrpe[4832]: Client request was invalid, bailing out…

    I did some google search on the error and it outlined that "dont_blame_nrpe = 1" in the NRPE2 config file on pfsense. I'm think this could be the issue but I am unsure how to make this change to validate this.

    Any ideas?



  • http://www.smallbusinesstech.net/more-complicated-instructions/nagios/setting-up-nagios-on-a-debian-server-to-remotely-monitor-an-untangle-server

    define service{
            use                            generic-service       
            host_name                      pfsense
            service_description          Current Load
            check_command check_nrpe_1arg!check_load
    }