Pfblocker stopped working…



  • I am a real dummy when it comes to this stuff, so please bear with me and my stupidity.

    Pfblocker has been installed on my firewall since since I started using Pfsense for the last 3 years. It has worked wonderfully!

    All of a sudden, it has stopped working. I can't block a country, IP, or anything. The only thing I do is keep Pfsense updated. I'm running the latest update.

    Can anyone help me with this? Surely others have had the same problem.

    Thanks!



  • If you recently updated pfSense.  Did you go back and re-enable pfBlocker?

    I've had occasion that I had to disable/enable (hit save each time) to get it to kick in.



  • Thanks for getting back to me.

    Yes, I checked and it was running. I disabled pfblocker and then enabled iagain, just in case. It still isn't working. I'm not sure when it stipped working, but I assume since the last update. I'm getting nailed big time from China. I can't stop them, they're all over me.



  • I'm running pfblocker 1.02, could this be the problem?

    To upgrade to the newer version, do I reinstall, pfblocker package, pfblocker's gui componets, or do I uninstall it and then install again?

    I can't afford to mess anything up!



  • Can you check your Firewall \ Rules \ WAN - to see if there is a pfblocker auto rule that has been created for each of your pfblocker lists ?

    This page https://forum.pfsense.org/index.php?topic=42543.705 talks about a bug that might be causing your problem.


  • Moderator

    It is recommended to use "Alias only" with pfBlocker. This way you manually add the rules to each interface which will give you more control and seems to work the best than trying to use the auto-rules etc…



  • Hey f34rinc, I checked and there are no entries for pfblocker auto rules, and there are not any. I have 2 lists, one list for "banned IPs" and a list for "allowed IPs" which allow IP's to bypass runles. Neitehr exists. Actually, nothing is in there from pfblocker.

    Any other ideas?



  • Upon further research, I see that pfblocker isn't showing up in Firewall->Rules->WAN.

    I uninstalled pfblocker, updated to the newest versiion of pfsense, and then installed pfblocker again. I'm still getting the same thing?

    Anyone know how to fix this issue?


  • Moderator

    @Bummer:

    Upon further research, I see that pfblocker isn't showing up in Firewall->Rules->WAN.

    I uninstalled pfblocker, updated to the newest versiion of pfsense, and then installed pfblocker again. I'm still getting the same thing?

    Anyone know how to fix this issue?

    How did you define the Blocklists in pfBlocker "LIST ACTION"?



  • From the link I posted earlier
    https://forum.pfsense.org/index.php?topic=42543.705

    @doktornotor:

    @nipstech:

    No I didn't. The only rules are the rules that block private and bogon networks.

    Well, that is the problem… Create something safe there (like, access from 127.0.0.1 to some port). Known bug.

    Try creating a dummy rule then try enabling pfblocker


Log in to reply