May 1 - pfSense 2.2-ALPHA - Package Installation Page Issue



  • pfSense is installed and it is passing traffic - this PC is behind the VM and I can use Diagnostics -> Ping

    When I go to install packages I get none listed and see: "Unable to communicate with https://packages.pfsense.org. Please verify DNS and interface configuration, and that pfSense has functional Internet connectivity."

    Configuration:
    pfsense 2.2-Alpha May 1 edition
    Hyper-V Server 2012 R2
    Supermicro A1SAi-2550F



  • Had some folks mention that I may just need to reboot. This did not help.

    In terms of communication, I can lookup and ping successfully.




  • Confirmed here as well, latest snapshot.  Communication is otherwise OK, packages.pfsense.org is reachable by name and IP.



  • Installed the may 5th snapshot and have this issue as well. I'm behind a verizon router on a subnet work that basically looks like this:

    Internet –-- Verizon Router ----- WAN ----- pfsense ----- LAN ---Computer
                          72.xx.xxx.xxx  192.168.1.xx                10.10.10.1

    Tried everything that was suggested for other versions including checking to prefer IPV4 versus IPV6 changing /etc/inc/Global.ini from https://... to http://... for the pfsense package location to disabling IPV6 (which is disabled at the verizon router). Nothing worked, can get out to the internet, can ping the the DNS server resolves to the right address just can't connect. >:(



  • Yup not working here either, was working before on earlier snapshots…

    I can see this in system.log when I click on the page if this helps :

    May  7 14:13:15 pfSense php-fpm[29935]: /pkg_mgr.php: XML_RPC_Client: Connection to RPC server                                packages.pfsense.org:443 failed. Unable to find the socket transport "https" - did you forget to enable it when you configured PHP? 103
    May  7 14:13:15 pfSense php-fpm[29935]: /pkg_mgr.php: XMLRPC communication error: Unable to find the socket transport "https" - did you forget to enable it when you configured PHP?

    Build details :

    [2.2-ALPHA][admin@pfSense]/root(7): uname -a
    FreeBSD pfSense 10.0-STABLE FreeBSD 10.0-STABLE #23 e852cd6(HEAD)-dirty: Tue May  6 04:20:00 CDT 2014    root@builder-10.0-b3-amd64:/usr/obj.amd64/usr/pfSensesrc/src/sys/pfSense_SMP.10  amd64

    [edit - fixed formatting]



  • I'm having the same issue here with my test installation. I have verified that I am online and don't have any issues with dns.



  • Right this appears fixed with the latest build I just updated to, the packages are back :)

    Build :

    FreeBSD pfSense 10.0-STABLE FreeBSD 10.0-STABLE #27 e852cd6(HEAD)-dirty: Wed May  7 19:01:34 CDT 2014    root@pf22-amd64-snap:/usr/obj.amd64/usr/pfSensesrc/src/sys/pfSense_SMP.10  amd64



  • ERROR: No digital signature! If you are SURE you trust this PBI, re-install with –no-checksig option.
    of squid-2.7.9_4-i386 failed!



  • If you do get the no digital signature message, but still want to install:

    Go to System -> Advanced -> Miscellaneous

    Then scroll to the bottom and there is a checkbox under Package settings that will allow you to install without the signature.



  • ok thanks