Help upgraded to 2.1.3 and Failed with error can't load kernel



  • Hey all,

    Been running pfsense 2.1-release for a while now. Decided to upgrade since my system was saying updates are available. Clicked to update and opted for a full system backup before upgrade. Process took a while I imagine because of the backup process. Anyway system rebooted and all I see is the BSD boot loader. It tries to boot but can't find the kernel.

    Does anyone have any advice? I'd really rather not lose my settings so if there is a way I can revert back or fix the kernel issue that would be great! I didn't grab a recent backup other than the one in the backup process thinking I'd be able to use it should I have issues with the upgrade! :(

    Hope you can help. Thanks!



  • I've read some info as I understand if I take the install CD and boot off it, I can run a "repair" install?

    Will this wipe anything?

    Thoughts?



  • What hardware are you running?
    Do you have a hard drive or flash install?

    If you have a copy of your original config.xml, it's probably simplest to try a new install and just restore the previous config.  That's usually the fastest and safest method when things go poorly.

    Failing that, you can use a Live CD to start a new install, but choose "Recover config.XML".

    This will start an instance of pfsense and attempt to locate your previous installation's partitions.

    It will let you shell out and access the original install under a mount point (/tmp/hdrescue (?) if I remember right).
    You can find your original config.xml in that tree.



  • Hey divsys,

    Thanks for the info. I've tried the rescue config method as I'm not sure how current my backup config is, if it would contain some settings I made recently.

    Anyway trying to confirm what is expected with the recovery mode. When I do this it scans my drive and then I see interface assignment settings. I did this and then the screen goes back to the menu where you can drop to shell, upgrade…etc.

    1. Is this correct and my config will be applied later?
    2. I dropped to shell and was able to locate my config under tmp/hdrecovery... Is there a way for me to save my config from here or will these directories be there after install?

    Hope you can help.

    Thanks



  • Hello divsys,

    To update: I've since managed to mount another usb stick and copy my config to it.

    For reference:

    
    mkdir /tmp/mnt/usb
    mount_msdosfs /dev/da1 /tmp/mnt/usb
    mkdir /tmp/mnt/usb/conf
    cp /tmp/hdrescue/cf/conf/config.xml /tmp/mnt/usb/conf/config.xml
    umount /dev/da1
    
    check it on another PC!!
    
    

    Re: installed normally (tried loading config from usbkey/conf/ directory but only got half my settings) so after install I restored my config again.

    So far looks good. Just waiting for packages to re: install now. I imagine I'll still be missing a few files…etc. but shouldn't be a big deal.

    Thanks so much for your help.

    Cheers! :)



  • Glad it worked out

    I still find the recovery tools built into pfsense saving my butt from time to time as well  :D

    The lesson I've learned (the hard way) is to make backups - often.