Squid2 consumes 100%CPU



  • Hi all,

    several old postings (from 2010) report a similar issue but I haven't found a working solution so far. The Squid Wiki suggests there might be /dev/null missing or a file system is mounted with nodev. But both seems to be ok with pfSense. :D

    I've installed latest pfSense together with the Squid package (2.7.9 pkg v.4.3.3).

    I've configured Squid as transparent proxy on one (out of 5) interface. Seems to work fine so far. :)

    Login to the command line and starting "top" shows 100% CPU usage by a squid process. ??? ::)

    Restarting the process resets the counter, but it's still using 100% CPU. :-\ >:( >:( >:( >:(

    Anyone having a clue or even better a working solution to reduce the CPU usage?

    Upgrading to Squid3 does not seem to be an options as I have to use Squidguard, too.

    Thanks!

    KNEBB

    Anyone having an idea



  • No one having an idea why my Squid is at 100% CPU?  :'(


Log in to reply