Squid3-dev causes Fatal error: Call to undefined function curl_init()

  • Pfsense 2.1.3 32-bit
    Ram 4 GB
    HDD 128 GB SSD
    CPU AMD Athlon 3400+ 64-bit
    1 Wan
    1 Lan

    Snort pkg v3.0.8 (off at testing, no rules selcted)
    pfBlocker 1.0.2 (disabled)
    Squid3-dev 3.3.10 pkg 2.2.2

    After installing a fresh 2.1.3 on the above box, snort disabled, pfblocker disabled.  I installed Squid3-dev and configured according to Eduardo Goncalves' instructions on his page http://egoncalves.com.br/pfsense/pfsense-squid3-dev-clamav-i386/

    After rebooting, I get this message in the dashboard, in the space where it indicates the latest version or update availability:

    Fatal error: Call to undefined function curl_init() in /etc/inc/pfsense-utils.inc on line 1639

    Once this message starts appearing, I cannot download any other packages, nor download snort rules, nothing.  Internet for LAN clients continues to work as normal and they can access the web.

    Line 1639 in /etc/inc/pfsense-utils.inc is this:

    $ch = curl_init();

    Does anyone have any ideas? I had all three packages configured previously on a different box, worked ok.  This is a new box and I did not import package configuration files on this build.  I have tried it with the old config.xml which contained package config info, but it does the same thing, so I tried doing it freshly configured and I still get this error. I did import a minimal config.xml during install for the firewall settings, but only the basics, no package config. The interfaces are different than what is originally in the config.xml, but it asks to reconfigure those during reinstall (with config.xml on usb stick) and Internet is functioning for computers on the LAN.  Help please :'(

Log in to reply