Installation Error 1



  • Hi All,

    A bit of a noob question. I've been using pfSense at work so thought I'd try and setup one at home (cos it's cool…and why not?).
    Trouble is I've never installed it from scratch so I thought I'd give it a try.

    The hardware I have to use is a Dell GX280 SFF (onboard Broadcom NIC), 2GB DDR2 RAM, Intel 1Gbps NIC. I'm trying to install version is 2.1.3-RELEASE (i386) on a Kingston Data Traveller Mini 1GB USB.

    So far I've managed to install the live version that runs from the CD (and configuring the LAN, WAN interfaces).
    When I try to install pfSense to the USB (option 99) i go through the wizard and select a easy install.
    I get the error code 1 (see attached photos)

    any ideas?
    ![photo 1.JPG](/public/imported_attachments/1/photo 1.JPG)
    ![photo 1.JPG_thumb](/public/imported_attachments/1/photo 1.JPG_thumb)
    ![photo 2.JPG](/public/imported_attachments/1/photo 2.JPG)
    ![photo 2.JPG_thumb](/public/imported_attachments/1/photo 2.JPG_thumb)


  • Netgate Administrator

    I would guess that your drive is reporting it's bigger than it actually is, or maybe the bios is.
    Do you not have a harddrive you can install to?

    Steve



  • hmmm…i've got a few 160GB hdds lying about, I was trying to make use of my USB keys.....seems a waste to install pfsense to a HDD of that capacity...


  • Netgate Administrator

    You could try a different usb drive, it should be able to install. However if you're installing to flash you should really be using the Nano images to avoid killing the drive with writes.

    Steve



  • Hi Guys,

    I have similar issue when installing via USB.
    I use win32diskimager and  this image : pfSense-memstick-2.1.3-RELEASE-i386-20140501-1552

    The system can boot using USB, and shows the pfsense options.
    When I select 99 to install to hardisk, and select easy install, appear errors as attached pictures. (seems to be similar with Bro "Error404")

    I have tried 3 different USB with different sizes 1G, 2G, 4G, and all similar result, always failed to install to hardisk.

    When I tried using nano image (pfSense-2.1.3-RELEASE-4g-i386-nanobsd-vga.img / pfSense-2.1.3-RELEASE-2g-i386-nanobsd-vga.img), there is no option to install to hardisk, and therefore when I reboot the pfsense, all erased, and installation begin again from the start.

    Would you be able to help or advise?

    Thank you,
    Best regards.







  • Netgate Administrator

    Hmm, well that looks like a possible bug. It's looking for the cleargpt.sh script but it's not there. That script formats the install drive.

    So you are booting from one USB flash drive (da0) and trying to install to another USB flash drive (da1)?

    When you use the Nano images there is no install process. The drive with Nano on it is already installed and ready to go. You should be able to reboot it and it will store it's settings on the flash drive. What happens that makes you think that is not happening?

    Steve



  • Hi Stephenw10,

    Actually I was just using one USB flash disk in da1 (not da0).

    From the log, it seems that the installation trying to format and install into da1 (the flashdisk itself), am I right?

    FYI, I have tried to install using CD-rom.
    Installation with CD-rom is working sucessfully on the same server. The installation will format into mfid0.
    But from the screenshot, it seems that the USB installation attempt to process in this sequence: cd0 da1 da0 mfid0 ?

    I have also tried to install using USB in older version:
    pfSense-memstick-2.1.2-RELEASE-i386-20140410-0523
    pfSense-memstick-2.1.1-RELEASE-i386-20140401-1525
    The results are similar as above, when I use pfSense-memstick-2.1.3-RELEASE-i386-20140501-1552.

    So at the moment, I suspect my installation process may not be correct, or if there is any boot settings that I have to modify?

    I would need to get USB installation working, and test it properly, because we plan to install pfsense into a different servers in remote location, which does not have any CD-rom or DRAC port.

    Thank you very much,
    Best regards!


  • Netgate Administrator

    Ah, well yes you can't install to the same drive you booted from.

    So the machine will boot from a CD and install the the mfid0 drive? But you can't install to mfid0 after booting from USB? Seems strange the memstick image is pretty much identical to the CD.

    Steve



  • Hello,

    When i will stare the pfsence firewall system that time with start up screen i get a mount root error please help me to solve this…


  • Netgate Administrator

    That is a different problem. Please start a new thread.
    Could be: https://doc.pfsense.org/index.php/Boot_Troubleshooting#Booting_from_USB

    Steve



  • @stephenw10:

    Ah, well yes you can't install to the same drive you booted from.

    So the machine will boot from a CD and install the the mfid0 drive? But you can't install to mfid0 after booting from USB? Seems strange the memstick image is pretty much identical to the CD.

    Steve

    Hi Steve,
    Sorry as I am not really system guy, so I am not very familiar and still learning, especially with FreeBSD things
    However, from the log, I suspect there is some problem with the  the order of booting in this server during installation.
    What do you think?
    How come the installation inspect cd0 first then da1 (USB flashdisk), then mfid0 last?
    While during CDrom installation, it immediately install into mfid0.

    To isolate the issue, I have tried below steps in the same server:

    1. I have tried different pfsense version using USB memstick –> getting similar issue.
    2. I have tried different USB flashdisk (1GB, 2GB, 4GB), --> getting similar issue
    3. I have tried different pfsense version using CDrom (2.1.1, 2.1.2, 2.1.3), --> can install successfully.
    4. I have tried using nano USB, it is working, but after initial setup and reboot, all gone. I have to reinstall everything again. --> success but have problem after reboot
    5. I have tried to set this setting but does not help:  set kern.cam.boot_delay="10000" --> getting similar issue

    Not sure if there is any steps I missed? Let me know if you have any suggestions that I can test?
    Thank you,
    Best regards!



  • Hi Steve, Guys,

    Thanks to my colleague's idea, and few more testing, I managed to complete the installation. Here are my steps.

    1. write the image into the USB flashdisk
    2. set the USB flashdisk as write-protect, using USB-WriteProtector (I use from http://www.gaijin.at/). This step is to avoid ad1 being formatted by the installer script.
    3. boot the server using USB flashdisk
    4. when installing pfsense to hardisk,  do not use easy install, and use manual install instead. Select the hardisk which you want to install pfsense into.
      I tried easy install, and apparently it will still try to format my USB flashdisk, causing installation to be failed again.
      So please use manual install instead.

    FYI, previously when the USB flashdisk is not write-protected, manual install was failed too.
    So I think write-protected USB flashdisk is really works to avoid this issue.

    Now my pfsense is up on 2.1.3, but I have different issue on the DHCP, but I will check it myself.
    Nevertheless installation is done.

    Thanks All  ;D
    Best regards,


  • Netgate Administrator

    Ah, nice one.  ;)

    Not really relevant any more then but…
    @twibowo:

    How come the installation inspect cd0 first then da1 (USB flashdisk), then mfid0 last?

    Alphabetical?  ;)
    It shouldn't make any different the order in which they are inspected. As you found the important part is that the easy install simply selects the first hard drive to install to. Fine if you booted from CD, not so much if you booted from what it considers a hard drive.

    Steve



  • late post.
    got mine working also…used the pfSense-memstick-2.1.3-RELEASE-i386(VGA).img.gz image. sounds simple enough.
    on a restart tho, is it suppose to ask to configure the vlans everytime?


  • Netgate Administrator

    No.
    It should only go back to the configure interfaces screen at the console if it can't find a valid config.xml file. That can happen if the config file is lost for some reason or if it contains a reference to a NIC that is no longer in the system. It also happens if you boot from the install media instead of the HD.

    Steve


Log in to reply