Pls help Multi wan with squid 2.7.9



  • Hi! I have successfully setup my pfsense 2.1.3 with muti wan (wan1 and wan2) I tried to monitor the ip when I change the gateway using this https://www.pfsense.org/ip.php and it works fine. but after I installed the squid and check the ip only I got the ip of the default wan(wan1). then I try to switch my gateway to wan2 and check my ip but my wan1 ip is seing.

    pls help how to solve this problem. squid is only works on default wan gateway, how to work it with multi wan?

    thanks in advance!!



  • This is a widely documented issue in the forums. No confirmed solution at the moment.



  • @waldopulanco:

    Hi! I have successfully setup my pfsense 2.1.3 with muti wan (wan1 and wan2) I tried to monitor the ip when I change the gateway using this https://www.pfsense.org/ip.php and it works fine. but after I installed the squid and check the ip only I got the ip of the default wan(wan1). then I try to switch my gateway to wan2 and check my ip but my wan1 ip is seing.

    pls help how to solve this problem. squid is only works on default wan gateway, how to work it with multi wan?

    thanks in advance!!

    The only workaround found so far is this one: https://forum.pfsense.org/index.php?topic=66822.msg374832#msg374832. However, you must have static WAN IPs for the gateways that you want to "load balance".



  • @georgio777:

    @waldopulanco:

    Hi! I have successfully setup my pfsense 2.1.3 with muti wan (wan1 and wan2) I tried to monitor the ip when I change the gateway using this https://www.pfsense.org/ip.php and it works fine. but after I installed the squid and check the ip only I got the ip of the default wan(wan1). then I try to switch my gateway to wan2 and check my ip but my wan1 ip is seing.

    pls help how to solve this problem. squid is only works on default wan gateway, how to work it with multi wan?

    thanks in advance!!

    The only workaround found so far is this one: https://forum.pfsense.org/index.php?topic=66822.msg374832#msg374832. However, you must have static WAN IPs for the gateways that you want to "load balance".

    thanks!! is it working on squid 2.7.9? it means it can cache wan1 and wan2? sorry I don't understand!



  • @waldopulanco:

    @georgio777:

    @waldopulanco:

    Hi! I have successfully setup my pfsense 2.1.3 with muti wan (wan1 and wan2) I tried to monitor the ip when I change the gateway using this https://www.pfsense.org/ip.php and it works fine. but after I installed the squid and check the ip only I got the ip of the default wan(wan1). then I try to switch my gateway to wan2 and check my ip but my wan1 ip is seing.

    pls help how to solve this problem. squid is only works on default wan gateway, how to work it with multi wan?

    thanks in advance!!

    The only workaround found so far is this one: https://forum.pfsense.org/index.php?topic=66822.msg374832#msg374832. However, you must have static WAN IPs for the gateways that you want to "load balance".

    thanks!! is it working on squid 2.7.9? it means it can cache wan1 and wan2? sorry I don't understand!

    i think you need to assign a static ip in your WAN and OPT1wan.
    usually it is set as DHCP in your WAN interfaces



  • @cheonne:

    @waldopulanco:

    @georgio777:

    @waldopulanco:

    Hi! I have successfully setup my pfsense 2.1.3 with muti wan (wan1 and wan2) I tried to monitor the ip when I change the gateway using this https://www.pfsense.org/ip.php and it works fine. but after I installed the squid and check the ip only I got the ip of the default wan(wan1). then I try to switch my gateway to wan2 and check my ip but my wan1 ip is seing.

    pls help how to solve this problem. squid is only works on default wan gateway, how to work it with multi wan?

    thanks in advance!!

    The only workaround found so far is this one: https://forum.pfsense.org/index.php?topic=66822.msg374832#msg374832. However, you must have static WAN IPs for the gateways that you want to "load balance".

    thanks!! is it working on squid 2.7.9? it means it can cache wan1 and wan2? sorry I don't understand!

    i think you need to assign a static ip in your WAN and OPT1wan.
    usually it is set as DHCP in your WAN interfaces

    yes my wan1 and wan2 is selected to static ip. but is not working. my pfsense version is 2.1.3

    thanks sir!



  • Sorry, I forgot to mention, the workaround only works on squid3.



  • @georgio777:

    Sorry, I forgot to mention, the workaround only works on squid3.

    Its Ok ;D


Log in to reply