Issue with SIP client behind the pfsense



  • I have a sip client registered on a public SIP server.
    My SIP client is behind of a pfsense, when I make calls, they connect, but the audio connection isn't established.

    I sniffed the traffic on a server and I noticed that the pfsense is sending the packet with the internal media IP.

    Is it a NAT problem?
    How can I fix it?

    Thanks for your time.



  • SIP isn't NAT friendly for just the reason you describe. There are a couple of ways to fix the problem.

    1. Tell your sip client to send the IP address of pfsense's WAN interface. Asterisk can do this, but I don't know of any other sip software that can.

    2. Tell your sip provider to configure your connection so that they ignore the ip address in the connection packet and instead use the actual source ip address of the connection.

    3. Use STUN, which is an automated way of performing option 1 above.



  • 4. use the siproxd package.


Log in to reply