[Solution] When Squid stops working after a reinstall…



  • Every time I re-install squid. Or try to reload from a previously working pfsense backup. Squid always ends up broken. The service says it's started, and nothing special is seen in the system logs. but if you look at the squid log or look into squidgard logs. It is basically disabled (In transparent mode). No amount of reinstalling packages regardless of order, fixes the problem. Even reloading from a fresh initialized pfsense (from a backup) didn't fix it. Which I assume is either because the packages are loaded in an order which squid seems to need to load first. Or maybe on of the error messages that happen with packages loading at boot reload time.

    All the fixes I read previously never worked for me, and is frankly a hassle after any restore. And this problem has been around for awhile.

    But I did find a fairly convenient solution, which is to "first" delete all your packages. (don't worry all the settings are still in pfsense) "Then" create a backup. Then fresh initialize your pfsense disk. Load your backup.

    This time PFSense will "not" reload your packages automatically from the reboot. But instead you now get to load them again through the packages tab. Starting with squid "first!".

    Fortunately all your settings will be picked up without trouble. And squid will immediately start working again.

    If your using squidguard, You will have to force it to re-download any blacklist.

    I find keeping a backup with all the packages deleted is better anyway for many reasons. As it always attempts to load everything itself. Many packages have problems loading from reload boot anyway.
    But it is a hassle to make because your deleting and reloading packages just for the sake of creating a backup file.

    I hope in the future the PFSense guys add a tick box to the backup button to just save package settings, but "not" load them upon restore. This is a big timesaver when something goes wrong and you have to do a total scratch reload.


Log in to reply