QOS w/ Vonage & Lost Bandwidth



  • I've recently installed pfSense 1.2-RC3 looking for a good way to manage QoS with a Vonage line.  I currently subscribe to Qwest's 1.5mbps down / 1.0mbps DSL service.  A speedtest to my ISP w/o traffic shaping configured shows the following throughput results:  1300kbps down / 820kbps up - and those numbers don't vary by much.

    Here's my problem:  when I am downloading (http, nntp, ftp) it usually stomps on the Vonage connection and I hear choppy voice.

    I ran through the QoS wizard and set things up properly.  I've verified by watching the queues that voice is in the VoIP queues and that the rest of the data is in qlan/qwandef.  I used 1200 as a number for qlanroot and 800 for qwanroot.  Voice is still choppy.  I turned down qlanroot to 1100 and things seem to clear up for the most part.  If I take it down to 1000 then things are perfect.

    The problem with this is that when I re-run the speedtest using the 1000/800 numbers in qos, my actual throughput drops to 700-800k range.  That means 24/7 I am missing out on almost half my bandwidth.

    My question is this:  Is there a way to limit all traffic to 1000 only while I am on the phone?  My ideal world would be to run it at 1200/800, which will prioritize data for the most part, but while I'm on the phone use 1000/800 (or even something more conservative) instead.

    Thanks!



  • Try to lower the qlimit on qVOIPup and qVOIPdown and tune acknowledgment too.
    Currently, iirc, they are set to 500 which if you ask me is somewhat not fine tunned but i might be wrong since those values are choosen by somebody else.

    Remember that 10% of the link are reserved by the shaper automatically to compensate for its internal working so you don't really loose bandwidth :).



  • @eri--:

    Try to lower the qlimit on qVOIPup and qVOIPdown and tune acknowledgment too.
    Currently, iirc, they are set to 500 which if you ask me is somewhat not fine tunned but i might be wrong since those values are choosen by somebody else.

    Where does one modify the qlimit?  I don't see that variable anywhere in the gui.  I've looked at /cf/conf/config.xml and the only queue that has a qlimit configured is qlandef.  I don't see qlimit tags on qVOIPup/down, and if I add the tags in and then disable/enable the traffic shaper through the GUI, all of the tags are re-written and the voip qlimit goes away.



  • @hidden772:

    @eri--:

    Try to lower the qlimit on qVOIPup and qVOIPdown and tune acknowledgment too.
    Currently, iirc, they are set to 500 which if you ask me is somewhat not fine tunned but i might be wrong since those values are choosen by somebody else.

    Where does one modify the qlimit?  I don't see that variable anywhere in the gui.  I've looked at /cf/conf/config.xml and the only queue that has a qlimit configured is qlandef.  I don't see qlimit tags on qVOIPup/down, and if I add the tags in and then disable/enable the traffic shaper through the GUI, all of the tags are re-written and the voip qlimit goes away.

    If you  have better defaults, by all means, please tell us.  QOS is quite the black art and we are always looking for help with this.



  • well try setting even the voip queues priority upper than ack queue



  • @sullrich:

    @hidden772:

    @eri--:

    Try to lower the qlimit on qVOIPup and qVOIPdown and tune acknowledgment too.
    Currently, iirc, they are set to 500 which if you ask me is somewhat not fine tunned but i might be wrong since those values are choosen by somebody else.

    Where does one modify the qlimit?  I don't see that variable anywhere in the gui.  I've looked at /cf/conf/config.xml and the only queue that has a qlimit configured is qlandef.  I don't see qlimit tags on qVOIPup/down, and if I add the tags in and then disable/enable the traffic shaper through the GUI, all of the tags are re-written and the voip qlimit goes away.

    If you  have better defaults, by all means, please tell us.  QOS is quite the black art and we are always looking for help with this.

    With the new shaper(new world order) you should be able to build the schema here quite easily using the gui and after that you can experiment with values.

    You cannot provide default values for everybody except those provided already from PF/ALTQ. Since even the tocken bucket needs tweaking for different scenarios. So let's wait till there to discuss this :).

    Regards



  • @eri--:

    With the new shaper(new world order) you should be able to build the schema here quite easily using the gui and after that you can experiment with values.

    You cannot provide default values for everybody except those provided already from PF/ALTQ. Since even the tocken bucket needs tweaking for different scenarios. So let's wait till there to discuss this :).

    I'm a newcomer to the pfsense project.  Does "new world order" describe an upcoming release?  Are you implying that the new shaper will be able to setup a schema that I have described as "ideal"?

    Thanks!



  • Well with the new shaper you will be able to setup/tweak the shaper to fit your needs.

    To make something clear.
    What you want to do is rather not realistic.
    When you setup the qlanroot to 1000 means that only then the queues becomes backlogged enough that the queueing discipline begins to do its magic. So to tweak it you usually even set the qlimit i told you lower(not possible in the current shaper, iirc) or setup the delay on HFSC realtime scheduer of VoIP queue to a better than the default and better than that of the ack queue.

    With the new shaper you would just choose the priq discipline for your link in the wizard and be done with it(I hope :)).

    So even tweak the current config you have or wait to try the new shaper.



  • When will this "new" shaper be available?



  • If no problems arise a image for testing should be a matter of days.


Log in to reply