Captive portal sync not work in CARP



  • Hello to all,

    I have cluster with 2 pfsense pc like attached image for my guest wlan.

    On the LAN created by pfsense a guest can connect without a password, authentication for the navigation is via voucher.

    The cluster works perfectly, everything is synchronized (firewall, NAT, DNS, DHCP) with exception of the captive portal, if the master server create vouchers on the slave server can not find them.

    Also if I turn off the master is impossible for me to navigate, I can not even presented with the login page voucher.

    I'm doing something wrong or captive portal login page, voucher, etc can not be synchronized?

    obviously I activate the sync option in High Avail. Sync -> Synchronize Captive Portal but I don't know what it synchronize

    greetings



  • guys,

    I have done several tests and now the sync works perfectly!!!  ;D if one of them falls the service is not interrupted.

    I just need a last step, the synchronization of the vouchers.

    I create vouchers from pfsense master, in the slave there is the option to sync the voucher to another server but I do not understand how to configure it:

    Voucher Synchronize Database IP: ip lan, ip wan, ip sync? which ip?
    Voucher sync port: which port?
    Voucher sync username: the name of the administrator?
    Voucher sync password: administrator password?

    I do not understand how to do it ….

    thanks



  • Hi,

    I was able to synchronize the voucher from master database using sync ip interface, such as the port on which expose the service and the credentials of administrator of pfsense.

    The synchronization works, in fact on the screen of the vouchers I have written:

    voucher Rolls
    (Synchronized from 192.168.0.1)

    At this point, however, is another issue, if I create new voucher on the master server, the slave does not sync automatically, even waiting a while, the only way I've found is to click again on "Save" in the page configuration.

    Obviously doing this manually is boring and unnecessary, it is his normal behavior or do I have to do?

    thanks


Log in to reply