[SOLVED] Manual packages failing to install



  • Suddenly with the new version of pfSense, I am no longer able to add packages manually. For example, on pfSense 2.1.3 if I try to add nano, I used to do the following from the command line:

    pkg_add -r ftp://ftp-archive.freebsd.org/pub/FreeBSD-Archive/ports/i386/packages-8.1-release/Latest/nano.tbz

    I notice that the release is up to 9.0 now. Should I use 8.1, 8.2, or 9.0 with the newest version of pfSense?

    either way, whenever I try any of those, I get the following output. I have tried from the default terminal and after typing "su -s" to get a # prompt. Doesn't matter, the output is the same (below):

    pkg_add -r ftp://ftp-archive.freebsd.org/pub/FreeBSD-Archive/ports/i386/packages-8.2-release/Latest/nano.tbz

    Fetching ftp://ftp-archive.freebsd.org/pub/FreeBSD-Archive/ports/i386/packages-8.2-release/Latest/nano.tbz… Done.
    Fetching ftp://ftp-archive.freebsd.org/pub/FreeBSD-Archive/ports/i386/packages-8.2-release/All/libiconv-1.13.1_1.tbz... Done.
    man/man1/iconv.1.gz: Failed to create dir 'man'Can't create 'man/man1/iconv.1.gz'
    man/man3/iconv.3.gz: Failed to create dir 'man'Can't create 'man/man3/iconv.3.gz'
    man/man3/iconv_open.3.gz: Failed to create dir 'man'Can't create 'man/man3/iconv_open.3.gz'
    man/man3/iconv_open_into.3.gz: Failed to create dir 'man'Can't create 'man/man3/iconv_open_into.3.gz'
    man/man3/iconv_close.3.gz: Failed to create dir 'man'Can't create 'man/man3/iconv_close.3.gz'
    man/man3/iconvctl.3.gz: Failed to create dir 'man'Can't create 'man/man3/iconvctl.3.gz'
    bin/iconv: Could not unlink
    include/iconv.h: Failed to create dir 'include'Can't create 'include/iconv.h'
    include/libcharset.h: Failed to create dir 'include'Can't create 'include/libcharset.h'
    include/localcharset.h: Failed to create dir 'include'Can't create 'include/localcharset.h'
    lib/libcharset.a: Could not unlink
    lib/libcharset.la: Could not unlink
    lib/libcharset.so: Could not unlink
    lib/libcharset.so.1: Could not unlink
    lib/libiconv.a: Could not unlink
    lib/libiconv.la: Could not unlink
    lib/libiconv.so: Could not unlink
    lib/libiconv.so.3: Could not unlink
    libdata/charset.alias: Could not unlink
    share/doc/libiconv/iconv.1.html: Failed to create dir 'share/doc'Can't create 'share/doc/libiconv/iconv.1.html'
    share/doc/libiconv/iconv.3.html: Failed to create dir 'share/doc'Can't create 'share/doc/libiconv/iconv.3.html'
    share/doc/libiconv/iconv_close.3.html: Failed to create dir 'share/doc'Can't create 'share/doc/libiconv/iconv_close.3.html'
    share/doc/libiconv/iconv_open.3.html: Failed to create dir 'share/doc'Can't create 'share/doc/libiconv/iconv_open.3.html'
    share/doc/libiconv/iconv_open_into.3.html: Failed to create dir 'share/doc'Can't create 'share/doc/libiconv/iconv_open_into.3.html'
    share/doc/libiconv/iconvctl.3.html: Failed to create dir 'share/doc'Can't create 'share/doc/libiconv/iconvctl.3.html'
    tar: Error exit delayed from previous errors.
    pkg_add: extract_plist: can not invoke 659 byte tar pipeline: /usr/bin/tar cf - man/man1/iconv.1.gz man/man3/iconv.3.gz man/man3/iconv_open.3.gz man/man3/iconv_open_into.3.gz man/man3/iconv_close.3.gz man/man3/iconvctl.3.gz bin/iconv include/iconv.h include/libcharset.h include/localcharset.h lib/libcharset.a lib/libcharset.la lib/libcharset.so lib/libcharset.so.1 lib/libiconv.a lib/libiconv.la lib/libiconv.so lib/libiconv.so.3 libdata/charset.alias share/doc/libiconv/iconv.1.html share/doc/libiconv/iconv.3.html share/doc/libiconv/iconv_close.3.html share/doc/libiconv/iconv_open.3.html share/doc/libiconv/iconv_open_into.3.html share/doc/libiconv/iconvctl.3.html|/usr/bin/tar --unlink -xpPf - -C /usr/local
    pkg_add: pkg_add of dependency 'libiconv-1.13.1_1' failed!
    Fetching ftp://ftp-archive.freebsd.org/pub/FreeBSD-Archive/ports/i386/packages-8.2-release/All/gettext-0.18.1.1.tbz... Done.
    pkg_add: could not find package libiconv-1.13.1_1 !
    pkg_add: pkg_add of dependency 'gettext-0.18.1.1' failed!

    Please help



  • So it turns out the file system I guess is now mounted read only. Maybe that's just the case with compact flash cards (nano installations). I was able to resolve this with the following:

    /etc/rc.conf_mount_rw

    Then do the pkg_add install

    /etc/rc.conf_mount_ro


  • Netgate Administrator

    It is just for Nano installs. The are mounted RO by default and should have been since 1.2.3.
    2.1.3 is built on FreeBSD 8.3 so you should be using those.  ;)
    Since 8.3 is still the current  it hasn't been archived yet so you can just add packages by their name directly without having to specify the entire path.

    Steve


Log in to reply