PPPoE broken on 1.2-RC3?



  • Hi everyone,

    I'm having problems getting PPPoE to work on 1.2-RC3.  I did a clean install to the hard drive and configure the 1 of the NICs on the system to connect via PPPoE as WAN connection.  The system has 2 fxp, 1 dc, and 1 re NICs.  Below is the section of the system.log file:

    Jan  2 18:45:30 sits mpd:  MAGICNUM 66c86331
    Jan  2 18:45:30 sits mpd:  MRU 1500
    Jan  2 18:45:30 sits mpd:  AUTHPROTO CHAP MD5
    Jan  2 18:45:30 sits mpd: [pppoe] LCP: state change Req-Sent –> Ack-Sent
    Jan  2 18:45:30 sits mpd: [pppoe] LCP: rec'd Configure Ack #47 link 0 (Ack-Sent)
    Jan  2 18:45:30 sits mpd:  MRU 1492
    Jan  2 18:45:30 sits mpd:  MAGICNUM 63e157f8
    Jan  2 18:45:30 sits mpd: [pppoe] LCP: state change Ack-Sent –> Opened
    Jan  2 18:45:30 sits mpd: [pppoe] LCP: phase shift ESTABLISH –> AUTHENTICATE
    Jan  2 18:45:30 sits mpd: [pppoe] LCP: auth: peer wants CHAP, I want nothing
    Jan  2 18:45:30 sits mpd: [pppoe] LCP: LayerUp
    Jan  2 18:45:30 sits mpd: [pppoe] CHAP: rec'd CHALLENGE #1
    Jan  2 18:45:30 sits mpd:  Name: "mlbrflma71w"
    Jan  2 18:45:30 sits mpd:  Using authname "user@somewhere.net"
    Jan  2 18:45:30 sits mpd: [pppoe] CHAP: sending RESPONSE
    Jan  2 18:45:30 sits mpd: [pppoe] CHAP: rec'd SUCCESS #1
    Jan  2 18:45:30 sits mpd: [pppoe] LCP: authorization successful
    Jan  2 18:45:30 sits mpd: [pppoe] LCP: phase shift AUTHENTICATE –> NETWORK
    Jan  2 18:45:30 sits mpd: [pppoe] setting interface ng0 MTU to 1492 bytes
    Jan  2 18:45:30 sits mpd: [pppoe] up: 1 link, total bandwidth 64000 bps
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: Up event
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: state change Starting –> Req-Sent
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: SendConfigReq #231
    Jan  2 18:45:30 sits mpd:  IPADDR 0.0.0.0
    Jan  2 18:45:30 sits mpd:  COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
    Jan  2 18:45:30 sits mpd:  SECDNS 0.0.0.0
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: rec'd Configure Request #127 link 0 (Req-Sent)
    Jan  2 18:45:30 sits mpd:  IPADDR a.b.c.d
    Jan  2 18:45:30 sits mpd:    a.b.c.d is OK
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: SendConfigAck #127
    Jan  2 18:45:30 sits mpd:  IPADDR a.b.c.d
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: state change Req-Sent –> Ack-Sent
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: rec'd Configure Reject #231 link 0 (Ack-Sent)
    Jan  2 18:45:30 sits mpd:  COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
    Jan  2 18:45:30 sits mpd:  SECDNS 0.0.0.0
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: SendConfigReq #232
    Jan  2 18:45:30 sits mpd:  IPADDR 0.0.0.0
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: rec'd Configure Nak #232 link 0 (Ack-Sent)
    Jan  2 18:45:30 sits mpd:  IPADDR e.f.g.h
    Jan  2 18:45:30 sits mpd:    e.f.g.h is OK
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: SendConfigReq #233
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: rec'd Configure Nak #233 link 0 (Ack-Sent)
    Jan  2 18:45:30 sits mpd:  IPADDR e.f.g.h
    Jan  2 18:45:30 sits mpd:    e.f.g.h is OK
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: SendConfigReq #234
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: rec'd Configure Nak #234 link 0 (Ack-Sent)
    Jan  2 18:45:30 sits mpd:  IPADDR e.f.g.h
    Jan  2 18:45:30 sits mpd:    e.f.g.h is OK
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: SendConfigReq #235
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: rec'd Configure Nak #235 link 0 (Ack-Sent)
    Jan  2 18:45:30 sits mpd:  IPADDR e.f.g.h
    Jan  2 18:45:30 sits mpd:    e.f.g.h is OK
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: SendConfigReq #236
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: rec'd Configure Nak #236 link 0 (Ack-Sent)
    Jan  2 18:45:30 sits mpd:  IPADDR e.f.g.h
    Jan  2 18:45:30 sits mpd:    e.f.g.h is OK
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: SendConfigReq #237
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: rec'd Configure Nak #237 link 0 (Ack-Sent)
    Jan  2 18:45:30 sits mpd:  IPADDR e.f.g.h
    Jan  2 18:45:30 sits mpd:    e.f.g.h is OK
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: SendConfigReq #238
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: rec'd Configure Nak #238 link 0 (Ack-Sent)
    Jan  2 18:45:30 sits mpd:  IPADDR e.f.g.h
    Jan  2 18:45:30 sits mpd:    e.f.g.h is OK
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: SendConfigReq #239
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: rec'd Configure Nak #239 link 0 (Ack-Sent)
    Jan  2 18:45:30 sits mpd:  IPADDR e.f.g.h
    Jan  2 18:45:30 sits mpd:    e.f.g.h is OK
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: SendConfigReq #240
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: rec'd Configure Nak #240 link 0 (Ack-Sent)
    Jan  2 18:45:30 sits mpd:  IPADDR e.f.g.h
    Jan  2 18:45:30 sits mpd:    e.f.g.h is OK
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: not converging
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: parameter negotiation failed
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: state change Ack-Sent –> Stopped
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: LayerFinish
    Jan  2 18:45:30 sits mpd: [pppoe] bundle: CLOSE event in state OPENED
    Jan  2 18:45:30 sits mpd: [pppoe] closing link "pppoe"…
    Jan  2 18:45:30 sits mpd: [pppoe] link: CLOSE event
    Jan  2 18:45:30 sits mpd: [pppoe] LCP: Close event
    Jan  2 18:45:30 sits mpd: [pppoe] LCP: state change Opened –> Closing
    Jan  2 18:45:30 sits mpd: [pppoe] LCP: phase shift NETWORK –> TERMINATE
    Jan  2 18:45:30 sits mpd: [pppoe] setting interface ng0 MTU to 1500 bytes
    Jan  2 18:45:30 sits mpd: [pppoe] up: 0 links, total bandwidth 9600 bps
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: Down event
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: state change Stopped –> Starting
    Jan  2 18:45:30 sits mpd: [pppoe] IPCP: LayerStart
    Jan  2 18:45:30 sits mpd: [pppoe] closing link "pppoe"…
    Jan  2 18:45:30 sits mpd: [pppoe] LCP: SendTerminateReq #48
    Jan  2 18:45:30 sits mpd: [pppoe] LCP: LayerDown
    Jan  2 18:45:30 sits mpd: [pppoe] bundle: OPEN event in state CLOSED
    Jan  2 18:45:30 sits mpd: [pppoe] opening link "pppoe"…
    Jan  2 18:45:30 sits mpd: [pppoe] link: CLOSE event
    Jan  2 18:45:30 sits mpd: [pppoe] LCP: Close event
    Jan  2 18:45:30 sits mpd: [pppoe] link: OPEN event
    Jan  2 18:45:30 sits mpd: [pppoe] LCP: Open event
    Jan  2 18:45:30 sits mpd: [pppoe] LCP: state change Closing –> Stopping
    Jan  2 18:45:30 sits mpd: [pppoe] PPPoE connection closed
    Jan  2 18:45:30 sits mpd: [pppoe] LCP: rec'd Terminate Ack #48 link 0 (Stopping)
    Jan  2 18:45:30 sits mpd: [pppoe] LCP: state change Stopping –> Stopped
    Jan  2 18:45:30 sits mpd: [pppoe] LCP: phase shift TERMINATE –> ESTABLISH
    Jan  2 18:45:30 sits mpd: [pppoe] LCP: LayerFinish
    Jan  2 18:45:30 sits mpd: [pppoe] device: DOWN event in state UP
    Jan  2 18:45:30 sits mpd: [pppoe] device is now in state DOWN
    Jan  2 18:45:30 sits mpd: [pppoe] link: DOWN event
    Jan  2 18:45:30 sits mpd: [pppoe] LCP: Down event
    Jan  2 18:45:30 sits mpd: [pppoe] LCP: state change Stopped –> Starting
    Jan  2 18:45:30 sits mpd: [pppoe] LCP: phase shift ESTABLISH –> DEAD
    Jan  2 18:45:30 sits mpd: [pppoe] LCP: LayerStart
    Jan  2 18:45:30 sits mpd: [pppoe] device: CLOSE event in state DOWN
    Jan  2 18:45:30 sits mpd: [pppoe] device is now in state DOWN
    Jan  2 18:45:30 sits mpd: [pppoe] device: OPEN event in state DOWN
    Jan  2 18:45:30 sits mpd: [pppoe] pausing 4 seconds before open
    Jan  2 18:45:30 sits mpd: [pppoe] device is now in state DOWN
    Jan  2 18:45:30 sits mpd: [pppoe] device: OPEN event in state DOWN
    Jan  2 18:45:30 sits mpd: [pppoe] device is now in state DOWN

    a.b.c.d is the gateway for PPPoE.
    e.f.g.h is the static IP of my connection.

    I know there's no problem with the NIC, DSL modem or the account because I can login fine on FreeBSD 6.2 Patch 9 on another slice in the same system.  I've tried to reset to factory default multiple times and still have the same problem.  All help and advises greatly appreciated.

    Thanks,
    Tommy





  • Thanks GruensFroeschli for the quick reply. I'll try the fix on the given link. :)


Log in to reply