Cant install freeradius



  • $ cat /tmp/pkg_mgr_freeradius.log
    Beginning package installation.
    Downloading package configuration file…
    freeradius-1.1.2_1 Array
    (
        [0] => tar: Error opening archive: Empty input file: Inappropriate file type or format
        [1] => pkg_add: tar extract of /tmp/apkg_freeradius-1.1.2_1.tbz failed!
        [2] => pkg_add: unable to extract table of contents file from '/tmp/apkg_freeradius-1.1.2_1.tbz' - not a package?
        [3] => pkg_add: 1 package addition(s) failed
    )

    Package WAS NOT installed properly.



  • I had the same problem today.



  • i tried to remove the /tmp/apkg_freeradius-1.1.2_1.tbz and install again, but same error



  • Yeah, I have the exact same problem.



  • The download package attempt seems to result in an empty file.  Perhaps the package configuration file is missing from the server now.



  • I have the same problem. I tried to install on my Alix, did the work to get it done with Live CD, but freeradius give in the install manager an error…



  • ALIX is embedded.
    To install packages you need the full version.
    The full version does not work on embedded hardware.

    Search the forum on how to run the full version on embedded hardware.
    You will need a harddisk for this.
    A CF card would die pretty fast..



  • But,.. did the full install on a microdrive.
    so full Pfsense installed.

    regards,



  • The package manager configuration file (pkg_config.xml on http://www.pfsense.com/packages/) seems to have the wrong URL for FreeRADIUS.  The archive can be found on the server if you correct the URL.  However, the package does not seem to be in a working state, so perhaps this is intentional until ready again.

    I experimented with the package a few weeks ago and found the additional features to be useful.  I am looking forward to testing again soon.



  • Any more on this? Does the package work and if so can it be installed from the CMD line ?



  • URL correct.  Thanks for the pointer.


Log in to reply