New install hardware failure?



  • I am running the following:
    A1SRi-2758
    8GB RAM
    Intel s3500 160GB
    AMD64 usb VGA 2.1.3

    I had some initial issues related to trying to install using the internal USB but I was able to switch over to the one on the back and it worked fine(USB3 issue?).  I have the IPMI port on the motherboard on dedicated mode hooked directly to desktop connection using static IPs (10.0.0.2 & 10.0.0.3).

    I am just trying to use the standard setups for pfsense to get going so I setup using just the auto detect during setup.  I get the auto port detection working for both WAN and LAN.  The WAN is going to my cable modem which has been power cycled before the plug in procedure.  The WAN is going to the other Ethernet port on my desktop.

    After the setup is complete I get no DHCP assigned IP on my desktop.  If I set a static 192.168.1.180 IP on the desktop I can't ping pfsense which should be running on 192.168.1.1.  No access to the web configuration of course.  Pfsense never shows that it gets any IP from the cable modem either.    Both WAN and LAN ports have activity lights active.

    The only thing I can see that might be an error is an occasional message in the console "igb3: could not setup receive structures".

    I am familiar with standard consumer routers (ddwrt and tomato) but am a bit lost on how to begin trouble shooting this I don't see any obvious logs to pull up via the console.  I assumed I should be good compatibility wise since there are "official" pfsense servers running what I believe is this same board or something similar (C2758 1U RACK MOUNT FIREWALL ROUTER SECURITY APPLIANCE).  I would appreciate any help.



  • I also tried hooking my desktop computer to the pfsense box using an hp switch, still no connectivity.



  • I also tried the following:
    https://redmine.pfsense.org/issues/1221
    Still not working.





  • I have heard of people using this board with minimal issues throughout the forum, certainly not what I am experiencing at least.  All 4 of my network interfaces seem to be detected correctly and report being connected during configuration.  Like I said there is official pfsense rangley products available so I am thinking this might not be a driver issue? 2.1.1 release notes report support for the i354 network interface.


  • Netgate Administrator

    Yep should be working. Did you try changing the numclusters?

    You could try a 2.2 snapshot, at least that will verify your hardware.

    To view the logs use clog:
    https://doc.pfsense.org/index.php/Why_can't_I_view_view_log_files_with_cat/grep/etc%3F_(clog)

    Steve



  • I tried adding the following to /boot/loader.conf.local:
    kern.ipc.nmbclusters="65536"
    hw.igb.num_queues="2"

    I will try one more fresh reinstall tonight when I get home then I might try out 2.2.  I'll report back with some debug logs if I see anything that might be an issue there.



  • It appears that this might be a hardware failure as I originally thought.  After loading Windows 7 x64 my network interfaces other than that dedicated IPMI one are not functional still.  Also failover on IPMI to the normal gigabit ports doesn't seem to work either.  Waiting to hear back from Supermicro support if I should send it back.


Log in to reply