LightSquid and 500 - Internal Server Error



  • I'm trying to get LightSquid to work, but all I am getting is a 500 - Internal Server Error when I go to the report tab.

    I am unfamiliar with FreeBSD so I have no idea where the log files are stored that would give a better idea of what is going on.

    I have hit the Refresh now button before clicking on the report tab.  I have done an un-install and re-installed but that made no difference.

    Thanks for your help.





  • @dvserg

    The Link you posted is just a discussion and not a bugfix.

    When will we get a Bugfix?



  • Topic have more? then one page
    Load this
    http://хххххх/libperl.so
    and replace
    /usr/local/lib/perl5/5.8.8/mach/CORE/libperl.so



  • it works

    thanks very much

    Giacomo



  • capitangiaco,

    How did you move the file to the pfsense server?  There is no FTP server on it and no wget so I can get the file directly from the box.

    Thanks!



  • one way is to install wget

    pkg_add -r wget

    otherwise use winscp or other proggie to copy file trough ssh

    /f



  • @dvserg:

    Topic have more? then one page
    Load this
    http://diskatel.narod.ru/libperl.so
    and replace
    /usr/local/lib/perl5/5.8.8/mach/CORE/libperl.so

    Thanks very much
    All its work !!!



  • @flachance:

    capitangiaco,

    How did you move the file to the pfsense server?  There is no FTP server on it and no wget so I can get the file directly from the box.

    Thanks!

    I downloaded it to another unix and used scp

    bye

    Giacomo



  • Actually, I remember that you can upload files from the Diagnostics: Command Prompt page.  It uploaded the file to /tmp and I opened a shell with putty and moved it to the location given by dvserg.

    Thanks everyone for the help.  It now works.

    I assume that the final release will not have two versions of Perl as this seems to be the root of this problem.



  • This is problem packet pearl-5.8.8._1 maintainer - not my. May be i rebuild this packet and place to pfSense server  >:(



  • @dvserg:

    Topic have more? then one page
    Load this
    http://diskatel.narod.ru/libperl.so
    and replace
    /usr/local/lib/perl5/5.8.8/mach/CORE/libperl.so

    I Had the same problem! TOO.

    It worked with me.
    Thanks for the solution and MORE Thanks toe everyone who posted the problem and insisted for the solution.

    .



  • In next week i update this package.
    Big thanks all, who helped fix this bug.



  • It is only to inform/report people that I have just tested with “1.2-RC4” and I Sill get “500 - Internal Server Error”, It is still necessary to do this (replace
    /usr/local/lib/perl5/5.8.8/mach/CORE/libperl.so)

    Regards

    @dvserg:

    In next week i update this package.
    Big thanks all, who helped fix this bug.



  • i have also this error with the recent build, and at the moment i haven´t seen a package update



  • Problem with perl-5.x.x.x_1 port (bad lib) This error have in some other packages.
    I can adding replacement this lib (from previous perl version) to LS package, but this not good idea.
    Maybe also remake Lighsquid package with excluding prel-.._1 and place this package to pfsense.com respository.

    Any comments or idea?



  • I cannot say what is the right way fro the specific problem, but for the future i think the package should work in future releases (perl , pfsense and others) without big efforts. Exchanging the libperl.so  from an older perl release is not really a good idea….
    Greetings
    Heiko



  • just a fyi, for all those wondering how to get the file on pfsense, the most direct approach would be to use 'fetch', which is included in at least the full package. you can access it from ssh / console / exec.php

    example:

    
    cd /tmp (for ssh/console)
    fetch http://diskatel.narod.ru/libperl.so
    mv /usr/local/lib/perl5/5.8.8/mach/CORE/libperl.so /usr/local/lib/perl5/5.8.8/mach/CORE/libperl.so.orig
    mv /tmp/libperl.so /usr/local/lib/perl5/5.8.8/mach/CORE/libperl.so
    
    


  • I have this same problem but I'm also seeing a corrupted pcre package error when I try to remove the lightsquid package.

    I'm not sure if this is related or not.

    Is the .htaccess security going to be fixed in a future version? Leaving it wide open naked for anything to peruse is a big no no on most networks.



  • Hello all, I get the 500 Internal Server Error when I try to get the graphics from Lightsquid.

    I followed this thread and made it up to the point where the conclisions are that the libperl.so file has to be replaced. Well, the link http://diskatel.narod.ru/libperl.so (mentiones early in this thread) seems not to exist any more. Anybody knows where can I get this file from ????

    Best regards



  • @ipnet:

    Hello all, I get the 500 Internal Server Error when I try to get the graphics from Lightsquid.

    I followed this thread and made it up to the point where the conclisions are that the libperl.so file has to be replaced. Well, the link http://diskatel.narod.ru/libperl.so (mentiones early in this thread) seems not to exist any more. Anybody knows where can I get this file from ????

    Best regards

    Pls restore you lib back and look lastest recomendations
    http://forum.pfsense.org/index.php/topic,11594.15.html
    –-
    Possible close this topic - here not actual information?


Log in to reply