Bandwidthd not working on new install of pfsense 2.1.3



  • I have recently installed the latest version (2.1.3 i386) on a new machine and cannot get bandwidthd operating correctly, just the message 'Please start bandwidthd to populate this directory. ' However, Status>Services shows that bandwidthd is running. Restarting the service completes with the message that bandwidthd has been restarted but still the same error message. Checking Status>Package logs says there are no packages with logging capabilities installed. Reinstalling the package gives no change. I've checked this for almost a week now, restarted, removed and reinstalled several times, searched online for fixes and tried them but have found nothing that works. Any help would be appreciated.


  • Rebel Alliance



  • I had already seen that post and followed those directions with no results (did that immediately before my posy yesterday). But maybe it just needed a few hours to ruminate on the matter (or maybe just the treat of getting the forum involved did the trick) because this morning bandwidthd is working. So after a week of searching, trying things, uninstalling, reinstalling, starting and restarting it suddenly decides it's time to go immediately after I make the posting.

    Such is life!



  • It's been a while since I played with bandwidthd, but as I recall it takes a little time after the first install to build a list of resources used and generate graphs.  Perhaps a little patience is all that was required from the start :)



  • For other readers, bandwidthd defaults to writing stats at 2.5 minute intervals. As long as there is more than the minimum traffic seen (about 1MB from memory) then there should be data and graphs generated within 5 minutes of enabling it.


Log in to reply