Multiple default gateways



  • I am trying to figure out why I have multiple gateways showing up by default for the same interfaces. I have an IPv6 link set up thru tunnel broker but why do i have 2 entries for the same interface showing up? making it really hard to correctly monitor the status as they seem to interfere with each other for updates. having them as default, i cannot delete them either.




  • Probably you are coming from a previous installtion.

    You should clean the config.xml by hand at this time since there were some changes done on this.



  • reset to default config maintains this issue.

    this is for a tunnelbroker interface. might explain the "tunnel" gateway that shows up.



  • I can confirm this issue over here!

    Steps to reproduce this error:
    1. Install pfSense 2.2 (ie. from scratch, do not import any previous configuration files)
    2. Configure your IPv6 (HE) tunnel
    3. Done, a bogus GW with the name of the tunnel's interface and an underscore popped up  :o

    Using
      2.2-ALPHA (amd64)
      built on Fri May 23 23:45:59 CDT 2014



  • I have a Multi WAN setup, no IPv6, this problem happens.

    On change IP Default WAN have Gateway pending and Dynamic DNS that depends on this gateway down. Today, after ISP change IP (36 in 36 hours), nobody can reach internet in this gateway,  edit or and apply  settings in gateway is a no go, all gateways show up still no internet in the default one restart apinger does't solve. My optional wan does't change IP allot  seems no problems.

    Rebooting i have similar behavior, default Gateway shows pending, Dynamic DNS in red (this theme is all red, makes me think that there are problems everywhere :P), restart gateway seems the problem gone.

    I have change allot of snapshots can't tell when this started happening but i remember last weak after reboot pfsense i have to restart apinger and apply Dynamic DNS settings to get green IP. I will test this better in the end of wake.

    1 WAN - pppoe
    2 WAN (OPT1) - ppp

    2.2-ALPHA (amd64)
    built on Mon May 26 10:16:02 CDT 2014
    FreeBSD 10.0-STABLE

    nanobds 1g



  • I can confirm that this issue is still there in latest snapshot 2.2 BETA built on Sat Nov 15 19:07:28 CST 2014.

    Tried HE.NET tunnelbroker today,  step by step using this tutorial,https://doc.pfsense.org/index.php/Using_IPv6_on_2.1_with_a_Tunnel_Broker

    and two IPv6 gateway showed up.



  • It's not two v6 gateways, it's one v4 and one v6. I fixed the description so it shows correctly. For gif and GRE it should only have either a v4 or a v6 gateway depending on which is in the tunnel network, but it doesn't hurt anything having both, one is just not going to do anything.