Webgui not working



  • Hello all.  I run a couple PFSense boxes for personal use.  I recently changed them all to use https.  2 of the boxes came back fine, but the one at my house will not.  When I check the net sockets it shows port 80, but the config says 443.  I tried to manually change it to port 80 in the config, but still a no go.  Any clue how I can get my gui interface back?  Running on port 80 is fine just so I can get back to the interface…

    I did look at restoring from a backup using the ssh login, but that change isn't showed in there.  Are the backup files held somewhere in the file structure?  I know how to use winscp to opull them over if I need to reload the box.  I just know know where the restore files sit.  I would just rather get the webgui going again...



  • Have you tried the "Restart webConfigurator" option from the console?

    I've had to do that once or twice to get a WebGui back up.



  • yes, I have tried that as well.  Still not go…  Where in the config files for lighttpd do you tell it to use https.  I would try changing that back to not use ssl since the netstats is telling me lighttpd is still on port 80.  The config says 443, but I don't know where the setting is to not use ssl or a cert.


  • Moderator

    Jimp posted a command to check that port setting from the shell.

    https://forum.pfsense.org/index.php?topic=77275.msg421291#msg421291



  • after doing a killall lighttpd and restarting it , /usr/local/sbin/lighttpd -f /var/etc/lighty-webConfigurator.conf  it now shows as port 443 as show below…  You can also see the .234 address which is me trying to access it.  However on different computers and browsers it says connecting and never does...  I tried to look at the lighttpd.log but it is all gibberish...

    root    lighttpd  88688 4  tcp4  *:443                :
    root    lighttpd  88688 5  tcp6  *:443                :
    root    lighttpd  88688 6  tcp4  192.168.1.1:443      192.168.1.234:52718



  • Have you tried a reboot on the box?

    It's also possible you may have accidentally set the WebGui to HTTP rather than HTTPS (even though it's using port 443).  That can make it a little quirky to connect with some browsers if they insist on using HTTPS the moment you specify port 443.

    I usually use something other than the standard HTTPS 443, and I've gotten the HTTP/HTTPS thing wrong on occasion leading to initial confusion when the GUI doesn't respond.



  • I already proved port 443 in both the sockets and the config.  The status on the browser does say connected but nothing comes up.  I have tried it from two different linux computers, a windows 7, and a windows 8 computer and it is still a no go…

    Yes, I also tried rebooting.  I have been working on this for over a week now.  That is why I came to the forum for help.


  • Netgate Administrator

    Right but as divsys said have you proved that the server isn't using http (non-encrypted) on port 443. That can make connection difficult because browsers try to be helpful by automatically using https as soon as you specify port 443 and vice versa.

    You could try re-assigning the LAN interface IP in the console menu via option 2. You can assign it the same address so that nothing changes but it should ask you 'do you want to revert to http?' or something similar to which you can answer yes. It doesn't on my 2.2 alpha test box I have here though.

    The config file is /conf/config.xml. If you SCP that off the box you can reset it to factory defaults or look through it for a config error (such as http on port 443). Yopu can try editing the file whilst on the box:

    ee /conf/config.xml
    

    Look in the <webgui>section.
    Change back to http on port 80 and then reboot. Obviously manually editing the config file is open to error.  ;)

    Steve</webgui>


Log in to reply