Pfsense 2.1.3 full install on esxi



  • hi!

    i just did a fresh install.

    setup a 10 gig hdd

    after installer finished i have only 2 gig partition set up

    what's about the rest of the hdd?

    regards

    cc


  • LAYER 8 Global Moderator

    What did you install?  Sure wasn't just pfsense..  I give pfsense 4 gig drive and have lots of space left way after install..  You got something running that is filling up the space - logs going crazy, I once forgot about a sniff and filled up disk space ;)

    [[2.1.3-RELEASE][admin@pfsense.local.lan]/root(12): df -H
    Filesystem    Size    Used  Avail Capacity  Mounted on
    /dev/da0s1a    3.1G    629M    2.2G    22%    /
    devfs          1.0k    1.0k      0B  100%    /dev
    /dev/md0      3.8M    67k    3.4M    2%    /var/run
    devfs          1.0k    1.0k      0B  100%    /var/dhcpd/dev
    [2.1.3-RELEASE][admin@pfsense.local.lan]/root(13): swapinfo -h
    Device          1K-blocks    Used    Avail Capacity
    /dev/da0s1b      1048576      0B    1.0G    0%
    [2.1.3-RELEASE][admin@pfsense.local.lan]/root(14):



  • well i think i did some error in translating from german to english

    so:

    i set up a virtual machine with 10 gig harddrive

    i tested a fresh full install v 2.1.2 and v 2.1.3

    after installing and doing a df -h it tells me that size of /dev/da0s1a is 2G

    [2.1.2-RELEASE][root@pfSense.localdomain]/root(1): df -h
    Filesystem    Size    Used  Avail Capacity  Mounted on
    /dev/da0s1a      2G    232M    1.6G    13%    /
    devfs          1.0k    1.0k      0B  100%    /dev
    /dev/md0      3.6M    50k    3.3M    1%    /var/run
    devfs          1.0k    1.0k      0B  100%    /var/dhcpd/dev

    what about the 8G of the hdd

    all prevoiusly installed pfsense versions always used the whole harddisk

    also to mention: at the end i can only select standard kernel and no symmetric muiltiprocessor kernel anymore

    did i miss something in the version history?

    regards

    karl



  • Did you do an automatic (Easy) or manual (Custom) install?

    I'd try a manual install and step through the drive sizing, so you can see where things go wrong.



  • Automatic(easy) as always

    Already did manual.same effect


  • LAYER 8 Global Moderator

    So pfsense is seeing full size of the disk you set?

    [2.1.3-RELEASE][admin@pfsense.local.lan]/root(24): dmesg | grep da0:
    da0: <vmware virtual="" disk="" 1.0="">Fixed Direct Access SCSI-2 device
    da0: 320.000MB/s transfers (160.000MHz DT, offset 127, 16bit)
    da0: Command Queueing enabled
    da0: 4096MB (8388608 512 byte sectors: 255H 63S/T 522C)</vmware>



  • yeap

    [2.1.3-RELEASE][root@pfsense]/root(1): dmesg | grep da0:
    da0: <vmware virtual="" disk="" 1.0="">Fixed Direct Access SCSI-2 device
    da0: 300.000MB/s transfers
    da0: Command Queueing enabled
    da0: 10240MB (20971520 512 byte sectors: 255H 63S/T 1305C)
    [2.1.3-RELEASE][root@pfsense]/root(2):

    [2.1.3-RELEASE][root@pfsense]/root(2): df -h
    Filesystem    Size    Used  Avail Capacity  Mounted on
    /dev/da0s1a      2G    646M    1.1G    36%    /
    devfs          1.0k    1.0k      0B  100%    /dev
    /dev/md0      3.6M    60k    3.3M    2%    /var/run
    devfs          1.0k    1.0k      0B  100%    /var/dhcpd/dev
    [2.1.3-RELEASE][root@pfsense]/root(3):</vmware>



  • How much RAM did you allocate to the image?

    The default installs typically allocate a swap space twice the size of your RAM, so 4GB of RAM takes 8GB of disk space, leaving you with 2G free.



  • @divsys:

    How much RAM did you allocate to the image?

    The default installs typically allocate a swap space twice the size of your RAM, so 4GB of RAM takes 8GB of disk space, leaving you with 2G free.

    Damn thats it - gave it 4 GB so it allocates 8 GB for swap

    thx for the hint



  • That's one of the reasons I often take the "extra" (120-150 secs) time to do a manual install.

    It reinforces all those automatic details that happen behind the scenes - and come back to bite you  ;)


Log in to reply