IGMP Proxy IPTV Enable Downstream locks web interface

  • Hi all

    I have PFSense connected to my Open Reach modem and all works well.  I have a BT You View box that won't show IPTV channels so I have enabled IGMP Proxy after reading various posts.  My problem is that when I enter IGMP Downstream details the web interfaces goes weird.  The system logs contain no detail and I'm unable to connect via SSH.  PFSense continues to work OK but I can't review logs as they are empty.  In addition the services all show stopped via the web interface although everything continues to work.  I'm using 2.1.3 have 3 NICS and the YouView box is connected to its own NIC.  The only option is to reboot the server by cutting the power.

    Anyone come across this or successfully managed to get PFSense, Open Reach modem and a BT You View box working correctly.

    Thanks in advance.


  • Can you get to a console on pfsense?

    You could try a "Restart WebConfigurator" from the console and see if that helps.

  • Hi Divsys

    Thanks for the quick reply, the web interface is running but I will try a restart.  I certainly can't SSH in once the lock happens and I can remove the two entries via the web interface before restarting.

    I have been testing more and its actually only happens when I enable both an upstream and downstream.  If I do just one it is fine and only causes the issue when I add both.  In my case the upstream is /4 and downstream to my local LAN that is dedicated to the You View box.

    I have done this with the You View disconnected in case it was causing IGMP flooding issues that I have read about.

    All a bit of a mystery, I wonder if I have a bug.  The only other packages installed are Squid-Dev and Sarg.


  • Do you need Squid/Sarge running to test this problem?

    If not, it might be worth disabling/uninstalling them to eliminate variables in the problem.

  • Hi

    Removed both packages and still have the problem.  Will try to connect via the console.


  • When the problem occurs you cannot use the console, type one key and it locks but the unit continues to route.

    Very odd.  I think I have found a bug with the combination of what I have.

    I reinstalled from scratch making sure I formatted the hard disk.  With the clean install I did the same test and problem persists.

    Simply add an upstream and downstream config.  The first you know of the problem is that the system logs contain no content and all the services show as stopped.  If you reboot the problem persists until you remove one or both entries against the IGMP Proxy, having done this you have to reboot and everything comes back to normal again.

  • What is your particular hardware setup?

    HD or CF
    Make of NICs

    How long has this unit been working?

    After you reformatted and did a clean install, did you install Squid and Sarge?

    Definitely very odd, especially to have the console lock up  :o

  • No solution to this strange phenomenon, just one thought: I may be wrong but I think you should not have as an upstream network.

    Did you configure any other upstream network? Does the TV set work? (You mention the unit "continues to route".)

    Btw. I have seen in examples for IGMP proxy setups for German IPTV configurations. I did my setup for IPTV without this and it works like this.

    As far as my knowledge goes the upstream networks configured in the IGMP proxy are matched against source addresses of IGMP packets coming in from the WAN side. A Multicast address is never a legal source address however so there should not be any packets with a source address in the network range.

    I can't imagine these things are related but on the off-chance that they are: Why not identify and configure correct upstream network ranges first …

  • Hi Divsis and -flo-

    Thanks for your replies.

    My setup is as follows:

    2GB RAM (Pfsense never takes more than 20% according to Dashboard)
    Centrino processor - HP motherboard
    HD is SATA 40GB and have loads of spare space
    NICS … need to check the make of these

    I have 3 NICS:

    -- one for WAN that does PPPtoe to the BT modem. - this NIC is built in to the motherboard.
      -- another for my local LAN on a 10.1.X.X range.
      -- another for another LAN (I'm in to Amateur radio and will be used for this) on a 10.2.X.X.

    After reformatting and installing I didn't install Squid or Sarg so they can be taken out of the equation now.  I also don't have captive portal running for now.

    The only other relevant thing is that I boot with ACPI disabled.

    After lockup, from the console you get a variety of faults.  Sometimes you get php errors for anything you run, this includes reboots other times it hangs.

    -flo- your answers:

    I put my You View box on the 10.2.X.X LAN and its the only device.  Everything works normally (streaming films and players) its only the Internet based channels that fail.

    When the PFSense has the problem, the box continues to route packets i.e everything appears to be working normally except you can't use the console and the web interface has no detail in the system logs (no records showing) and the services all show as stopped.

    I used these instructions to configure - http://www.dslreports.com/forum/r28895644-TDS-IPTV-Service-using-PFSense-Configuration-Instructions

    Interested in what you say about as an upstream.  I haven't tried configuring the other way round.

    "Why not identify and configure correct upstream network ranges first", I have tried both ways and get the same results.

    Thanks for your help both, very much appreciated.



  • I think you need to add another interface to your WAN side. The Multicast is delivered to the actual interface and NOT the PPPOE that the Internet uses.

    Just setup another interface on the WAN NIC, I called it IPTV_WAN. You have to give it an IP address but it can be anything. Use this new interface in the IGMP Proxy config for upstream.


  • I used these instructions to configure - http://www.dslreports.com/forum/r28895644-TDS-IPTV-Service-using-PFSense-Configuration-Instructions

    From your first post it looked like you are using BT as a provider, is that right? As far as I can tell from the link you provided the description contains the YouView box as a common denominator however TDS seems to be a different provider. In that case the informations given there will not work especially if it comes to the IP addresses provided for Multicast sources.

    First of all you should research whether or not BT serves internet and IPTV traffic in different VLANs. This is common. If so you must find out which VLAN IDs BT uses. This depends completely on the provider. Assuming BT uses VLANs you should create a WAN interface for internet traffic probably using PPPoE. As james_h wrote you need a second interface named IPTV_WAN (for example, any name will work). It may also be required to configure this interface with DHCP instead of a static IP address.

    Second you need the IP addresses of the BT upstream network sources for IPTV.

    I have seen this as a possible starting point: https://community.bt.com/t5/YouView-box/Using-a-3rd-party-router-for-Multicast/td-p/1048582 for further research.

    If nothing else helps then you can still employ Wireshark to do research directly on the cable. 8)

  • Hi

    Yes I'm using BT, will checkout the link thanks.