• So ever since an update in April, I have been unable to successfully use Squid or Squid3. It used to work and now it hasn't and I cannot find a way to solve this issue. So what I see under services is that Squid has stopped. It isn't activated. Now if I try to dabble with the settings and attempt to change it or activate it, I cannot connect to anything and it quickly stops the service. If it does work, then I have the "The requested URL could not be retrieved" error. I have tried reinstalls, restarts and just about everything I can think of.

    PC specs.

    AMD FX Quad core 2.6GHz
    6GB DDR3 RAM
    ASRock motherboard
    250GB HDD
    600 Watt PSU (Used to be a gaming PC)

    Squid settings

    Proxy Interface: LAN

    Allow users on interface: Y

    Transparent proxy: Y

    Bypass proxy for Private Address Space (RFC 1918) destination: N

    Bypass proxy for these source IPs: Blank

    Bypass proxy for these destination IPs: Blank

    Enable logging: N (Used to be Y)

    Proxy port: 3128

    ICP port: Blank

    Language: English

    Disable X-Forward: N

    Disable VIA: N

    What to do with requests that have whitespace characters in the URI: Allow (Used to be Strip)

    Use alternate DNS-servers for the proxy-server: Blank

    Suppress Squid Version: N

    Custom Options: Blank

    Cache Management:

    Hard disk cache size: 5000

    Hard disk cache system: ufs

    Hard disk cache location: /var/squid/cache

    Memory cache size: 1024

    Minimum object size: 0

    Maximum object size: 1024

    Maximum object size in RAM: 1024

    Level 1 subdirectories: 32

    Memory replacement policy: Heap LFUDA

    Cache replacement policy: Heap LFUDA

    Low-water-mark in %: 90

    High-water-mark in %: 95

    Do not cache: Blank (Used to have Speed Test)

    Enable offline mode: Y (Used to be N)
    Access Control:

    Allowed subnets: 192.168.1.1/24

    Is there anything I am missing? I have tried everything all the way to reinstalling PfSense.


  • Do you have a backup you can try to restore from?

    System -> Firmware -> Restore Full Backup
    or
    Diagnostics -> Backup/Restore