All NICs no longer work when I add a 4 port NIC card



  • I added a 4 port NIC card to the server and now the built in NIC cards do not respond to pings. Did not configure the new card yet.

    If I take the card out, the system works.

    No error messages reported on startup.  The card does work in a windows system.


  • Rebel Alliance Developer Netgate

    Does the new card use the same type of NIC as your existing NICs?

    The new card would change the probe order, so imagine this:

    Existing #1: em0 (WAN)
    Existing #2: em1 (LAN)

    Add the four port nic:

    New #1: em0 (WAN)
    New #1: em1 (LAN)
    New #1: em2
    New #1: em3
    Existing #1: em4
    Existing #2: em5

    Your current ports may have "relocated" to be ports on the new card rather than onboard or current expansion cards.



  • I thought of that, none of the new ports show up so I am guessing it is a driver issue.


  • Rebel Alliance Developer Netgate

    Could be. See the doc wiki page on NIC tuning, perhaps it needs some tunables set to work.

    It may also require using 2.2 with its newer driver base, but it's still alpha.



  • I do not have access to the GUI however now under assign interfaces all the nic cards show up.

    em0 … em5
    em0 and em1 are up as they should be.
    When I plug in a cable to the new card I get a link light but the state of the card does not change to up. (I looked in assign interfaces)
    I ran pciconf -l and it shows all the ports.
    The driver for all of them is using the Intel Pro1000 driver.

    I am using 2.2 now, I upgraded.



  • I put an IP address on each nic for the LAN just to see if the port changed and tried to ping each nic.
    Nothing.
    I disabled the firewall to see if it was blocking and still nothing.
    I even tried to access the system on the WAN interface with the firewall disabled and nothing.
    Pings from the system out also fail.
    On Server:
    em0 - 10.20.0.1 LAN
    em1 - 192.168.1.2 WAN
    On New Nic
    em2 - 10.20.0.249 OPT1
    em3 - 10.20.0.248 OPT2
    em4 - 10.20.0.247 OPT3
    em5 - 10.20.0.246 OPT4
    I connected every nic to the switch and now I can ping and get to the web interface but only on 10.20.0.1.

    When I unplug one of the cables on the new nic, the pings stop so I see that it is now on another spot. the em#'s do not seem to match the ip's just going by the position so I will troubleshoot them and maybe reset all the settings.
    I still cannot ping the wan side.


  • Netgate Administrator

    Just pointing out that these two threads are now pretty much duplicated:
    https://forum.pfsense.org/index.php?topic=77610.0

    Steve



  • I got it working, reset to factory default and redid the settings and it now works under 2.2

    Thanks for all your help.


Log in to reply