• Been waiting for the GUI bug that has been affecting the recent snaps to be fixed to test out 2.2 on my home network so I upgraded from 2.1.3 to the June 3rd 1343 64 bit snap today and the upgrade froze at firmware upgrade in progress.  Forced a reboot and I got the following error on the console.

    Call to undefined function pfSense_interface_listget() in /etc/inc/interfaces.inc on line 66.

    Figured I botched the upgrade so I downloaded the Full ISO and proceeded to install from scratch but once installed and booted I got the exact same error.  pfSense doesnt get an IP and there are obviously no interfaces listed.  This is with a dual Intel PCIe card, em driver.

    Installed 2.1.3 and I'm back in business so its not a malfunction with my card.


  • I can confirm.

    I thought is something from my installation, tested in a VM and works fine. I have dual Intel using em driver.

  • Netgate Administrator

    Yep present in 32 and 64bit Nano builds.

    Steve


  • Hmm, a rather important shared library seems to be missing from the build:

    On a working system (20-May):

    [2.2-ALPHA][root@pfsense.localdomain]/usr/local/lib/php(118): ls -l */pfSense.so
    -r-xr-xr-x  1 root  wheel  1549711 Apr 25 19:53 20090626/pfSense.so
    -r-xr-xr-x  1 root  wheel  1631611 May 20 15:56 20121212/pfSense.so
    [2.2-ALPHA][root@pfsense.localdomain]/usr/local/lib/php(119): grep pfSense_interface */*.so
    Binary file 20090626/pfSense.so matches
    Binary file 20121212/pfSense.so matches
    
    

    From tonight's broken one (pfSense-LiveCD-2.2-DEVELOPMENT-i386-20140603-0946.iso.gz):

    [2.2-ALPHA][root@pfsense.localdomain]/usr/local/lib/php(67): ls -l */pfSense.so
    ls: No match.
    [2.2-ALPHA][root@pfsense.localdomain]/usr/local/lib/php(68): grep pfSense_interface */*.so
    [2.2-ALPHA][root@pfsense.localdomain]/usr/local/lib/php(69):
    
    

    edit: add version info


  • I'm not seeing this error on my setup. I'm running amd64-20140603-1343.


  • I updated an Alix 2GB 32-bit system using pfSense-2.2-DEVELOPMENT-2g-i386-nanobsd-upgrade-20140603-1850.img.gz
    When its network did not come back, I connected the serial console and pressed enter and got this:

    FreeBSD/i386 (Amnesiac) (console)
    
    *** Welcome to pfSense 2.2-ALPHA-nanobsd (i386) on testoffice-rt-01 ***
    
    Fatal error: Call to undefined function pfSense_interface_listget() in /etc/inc/                          interfaces.inc on line 66
    
     0) Logout (SSH only)                  8) Shell
     1) Assign Interfaces                  9) pfTop
     2) Set interface(s) IP address       10) Filter Logs
     3) Reset webConfigurator password    11) Restart webConfigurator
     4) Reset to factory defaults         12) pfSense Developer Shell
     5) Reboot system                     13) Upgrade from console
     6) Halt system                       14) Enable Secure Shell (sshd)
     7) Ping host                         15) Restore recent configuration
    
    Enter an option:
    
    

    Looks like this problem is common to many (or all) current builds.
    Time to switch back to the other slice…


  • I upgraded to…

    2.2-ALPHA (i386)
    built on Tue Jun 03 18:50:14 CDT 2014
    FreeBSD 10.0-STABLE

    Without any problems.


  • @adam65535:

    I upgraded to…

    2.2-ALPHA (i386)
    built on Tue Jun 03 18:50:14 CDT 2014
    FreeBSD 10.0-STABLE

    Without any problems.

    The question is, nanobsd or full?

    My VM works, my nonobsd box have this problem. To help please specify more. Thanks


  • I see this error too on the: pfSense-LiveCD-2.2-DEVELOPMENT-amd64-20140603-1343 build.

    I did a fresh/new install


  • 2.2-ALPHA (i386)
    built on Tue Jun 03 18:50:14 CDT 2014
    FreeBSD 10.0-STABLE

    This was the full version that I upgraded that worked without problems.


  • yes, the module is missing on amd64, but not i386.

    it's being fixed.

  • Developer Netgate Administrator

    It's now fixed. Thanks!