Configuring and Installing on an old HP Pavilion desktop not working



  • Greetings all.  First I apologize if this came up, I tried searching the forums a bit and didn't find anything, but was not as thorough about it as I maybe could be.  Anyway, I have a bit of a peculiar set up.  Please view the attached image it contains all the details about the equipment I'm using.  So I tried configuring my ethernet cards with a pfSense install disk I made.  I set eth0 to WAN, eth1 to LAN, and eth2 & eth3 as OPT1 & OPT2 respectively.  After that I installed pfSense to the hard drive and rebooted.  The following came up:

    F1 pfSense

    F6 PXE
    Boot:  F1

    So I chose F1 and a backslash above a blinking cursor pops up on the screen and nothing else.  Does that mean it has booted up?  I'm skeptical.  I tried rebooting and chose the F6 option and that just spewed out a bunch of errors.

    Otherwise, when I try plugging another computer into one of the LAN ports I configured so I can access the web gui, I am unable to do so.

    Does anyone have an idea of where I may have gone wrong?
    ![Proposed Network Setup.jpg_thumb](/public/imported_attachments/1/Proposed Network Setup.jpg_thumb)
    ![Proposed Network Setup.jpg](/public/imported_attachments/1/Proposed Network Setup.jpg)



  • Well, it's certainly not a successful install if you don't get a long bunch of boot console messages and end up with a menu and responsive cursor, unless you did something like use the embedded version that has only a serial console on a regular system with a console display. IIRC (it's been a while) setting the interfaces in the LiveCD session doesn't do a thing for the hard disk installed version, so it could be sitting there asking the serial console for interface assignments, IF that's what's happened.

    Try reinstalling, or try verifying that you have the right image for a computer with display install and then try reinstalling. You may also need to fiddle with BIOS settings - I had issues with needing to set SATA hard disks to "legacy" mode on my system, for instance.


  • Netgate Administrator

    What you are describing is 'hung at the spinner'. That backslash is supposed to rotate as the kernel initially loads.
    For suggested solutions see:
    https://doc.pfsense.org/index.php/Boot_Troubleshooting#BIOS.2FDisk_Errors

    You're using the terms eth0-3 but those are Linux terms. pfSense is built on FreeBSD and doesn't use those names for NICs. What hardeware are you using? I don't see pfSense in your diagram.

    Steve


Log in to reply