[resolved] pfSense with Intel EXPI9402PTBLK



  • I am working on my first install of pfSense and the first problem I have encountered is the speed on one of the ports of my Intel EXPI9402PTBLK, a dual-port 10/100/1000 PCIe card, being automatically set to 10/100. If I try to set the interface for the card to autoselect or 10/100/1000, it doesn't work - I can seen the link lights turn on and off every few seconds. This card has worked fine with other OSs, including Windows 7 and Ubuntu.

    The card is set to have one port (em1) as the LAN port for the system and second port (em0) is not yet configured. I am using the motherboard port (em2) for WAN and I'm running pfSense 2.1.3 from a live CD with CF card for configuration saves.

    Edit: Just noticed that during boot all three devices are reported as Intel(R) PRO/1000 Network Connection 7.3.8


  • Netgate Administrator

    A bad cable would produce those symptoms. 4 wires required for 10/100 but all 8 for 1000Mbps.

    Steve



  • Thanks. Sorry, I didn't come back and close this one. There was a motherboard issue related to (very old) BIOS. Updated BIOS, everything worked as it should. Quite a bit of googling to find that one.


Log in to reply