Squid3-dev + pfsense 2.1.3 = "No such process" & no internet in transparent mode



  • Hi There,

    I just updated the Firewall and got a new problem now.
    squid won't work, if i restart the service, i'm getting the following entries @ log:

    
    Jun 6 16:09:22	squid[3207]: Squid Parent: (squid-1) process 3813 started
    Jun 6 16:09:22	squid[3207]: Squid Parent: will start 1 kids
    Jun 6 13:09:20	check_reload_status: Reloading filter
    Jun 6 16:09:20	php: /status_services.php: The command '/usr/local/etc/rc.d/squid.sh stop' returned exit code '1', the output was 'squid: ERROR: Could not send signal 15 to process 62597: (3) No such process'
    Jun 6 16:09:19	Squid_Alarm[99108]: Squid has resumed. Reconfiguring filter.
    Jun 6 13:09:19	check_reload_status: Reloading filter
    Jun 6 16:09:19	Squid_Alarm[98090]: Reconfiguring filter...
    Jun 6 16:09:16	squid[95459]: Squid Parent: (squid-1) process 95545 started
    Jun 6 16:09:16	squid[95459]: Squid Parent: will start 1 kids
    Jun 6 16:09:15	Squid_Alarm[93553]: Attempting restart...
    Jun 6 16:09:15	Squid_Alarm[93237]: Squid has exited. Reconfiguring filter.
    Jun 6 16:09:15	php: /status_services.php: The command '/usr/local/etc/rc.d/squid.sh stop' returned exit code '1', the output was 'squid: ERROR: Could not send signal 15 to process 62597: (3) No such process'
    
    

    i'd like to use squid only for monitoring the internet activity (due to law) and wanted to access the monitored information with lightsquid.

    when i'm setting squid to transparent mode, my internet connection is killed - all clients had no more internet.

    I tried following how-to's:
    https://doc.pfsense.org/index.php/Setup_Squid_as_a_Transparent_Proxy
    http://hubpages.com/hub/How-to-setup-a-transparent-proxy-using-pfSense

    After two days of testing, i'd like to ask the community - just want to ged rid of this problem :(


Log in to reply