Squid 3.3.10 pkg 2.2.4 not starting



  • Hi @ll

    Cannot get Squid to start after update to 3.3.10 pkg 2.2.4, ich get the following error message :

    
    php: /status_services.php: The command '/usr/local/etc/rc.d/squid.sh stop' returned exit code '1', the output was 'FATAL: No valid signing SSL certificate configured for https_port <my_public_ip>:443 Squid Cache (Version 3.3.10): Terminated abnormally. CPU Usage: 0.019 seconds = 0.009 user + 0.009 sys Maximum Resident Size: 30560 KB Page faults with physical i/o: 0'</my_public_ip> 
    

    followed by

    
    squid: No valid signing SSL certificate configured for https_port <my_public_ip>:443</my_public_ip> 
    

    How is it about the SSL certificate ? Do I need this ? I was using Squid before and never got this message
    or requirement before

    Thanks in advance for any hint

    cheers thafener



  • Disable SSL filtering in Squid options, or generate a valid cert using the certificate manager and then specify that one in the proxy config.



  • Nothing related to SSL filtering is enabled but I still get the error message



  • Updated to pkg 2.2.5 yesterday, Squid refuses to start. However the error message has changed, it is now :

    
    php: /status_services.php: The command '/usr/local/etc/rc.d/squid.sh stop' returned exit code '1', the output was '2014/06/10 13:23:33| parse_peer: token='round-robinssl' FATAL: Bungled /usr/pbi/squid-i386/etc/squid/squid.conf line 98: cache_peer 10.0.0.10 parent 443 0 proxy-only no-query no-digest originserver login=PASSTHRU round-robinssl sslflags=DONT_VERIFY_PEER front-end-https=auto name=rvp_exchange Squid Cache (Version 3.3.10): Terminated abnormally. CPU Usage: 0.015 seconds = 0.007 user + 0.007 sys Maximum Resident Size: 29312 KB Page faults with physical i/o: 0'
    
    

    and then :

    
    squid: Bungled /usr/pbi/squid-i386/etc/squid/squid.conf line 98: cache_peer 10.0.0.10 parent 443 0 proxy-only no-query no-digest originserver login=PASSTHRU round-robinssl sslflags=DONT_VERIFY_PEER front-end-https=auto name=rvp_exchange
    
    

    Obviously there is some code in the config pointing to a server that does not exist any more. Can I delete this line ? I could not find any point in
    the GUI pointing to this retired server and I have never configured a chache_peer.

    Thank you for your hints

    cheers thafener


Log in to reply