No IP in DHCP WAN



  • Hi !

    First, sorry for my english (i'm french)  :( ;D

    I have  an fiber connection and with a new Netgear router (in DHCP), no problem (i have an IP and i can surf)… When i plug my pfsense router (last update), i have no IP in DHCP WAN…

    I don't understand why…

    Have you an idea ?

    One more thing : in another connection (in ADSL), i have an IP in DHCP mode with the same pfsense router and everything is fine…



  • Did, you plug the Netgear Router into the fiber connection before trying pfsense?

    It may be that the fiber gear is remembering the MAC from the Netgear and refusing to give you a new IP address.
    Who's providing your fiber connection?  Do they give you any instructions about changing attached devices to their connection?

    Worst case, you could try to spoof the MAC address from the Netgear box in your pfsense setup: Interfaces->WAN->Mac Address

    Welcome to pfsense  :)



  • Hi divsys !

    i had the same idea : spoofing MacAddress of my Netgear… I try this and i'll tell you…

    For information, the provider is SFR Pro.


  • LAYER 8 Global Moderator

    SFR that is French is it not?  I know there is some fiber providers in Norway that have their dhcp servers over 16 hops..  There is a bug in dhcp client in bsds that limit to 16 TTL..  I had put in a bug report couple years back that finally patched, but doubt the code has been put in place yet.

    Has any pfsense install worked, or bsd for that matter?  But yes it is common for changing in the device to the modem required a reboot of the modem to allow new mac to work.  Changing the mac is not best option.. Easier to just power cycle the device from your isp before you connect different device.

    If that doesn't work - if you dhcp server is lots of hops away it could be related to the 16 ttl that is set on the dhcp stuff.



  • Hi johnpoz !

    Yes SFR is French…

    I'll try to reboot SFR's device too…

    Thanks a lot.


Log in to reply