Device on LAN can't ping device on LAN2.



  • Set up LAN2 for my Dell Poweredge 860 which is an ESXi host running a Windows VM that has game servers on it.  I had this working fine before, but now that I've started over I can't seem to get it to work properly.  When I try to ping the windows VM on LAN2 from my rig on LAN, it fails.  I can vSphere in to the ESXi host and ping the ESXi host, though.

    WAN Firewall Rules…

    LAN Firewall Rules…

    LAN2 Firewall Rules…

    NAT Rules…

    So far I should have MS RDP and Minecraft ports forwarded as you can see in the last screenshot.  You'll also notice that I blocked traffic from LAN2 to LAN1, that is intentional.

    So why can't I ping a LAN2 device from LAN?  Pretty sure these were the same exact settings I had before when I had Starbound, Terraria, 7 Days To Die, and Minecraft all running on this server.  The only different is I'm using different subnets for my LANs and pfSense is on a firebox now instead of a VM on my ESXi host.



  • Not sure what happened but I lost internet and network connectivity in that Windows VM.  I can't even ping the LAN2 interface from that VM anymore, but it's showing that it is connected to a network.  ESXi network settings look fine, didn't touch them.



  • @opjohnny:

    Not sure what happened but I lost internet and network connectivity in that Windows VM.  I can't even ping the LAN2 interface from that VM anymore, but it's showing that it is connected to a network.  ESXi network settings look fine, didn't touch them.

    Since you are able to ping and connect to the ESXi host, it sounds to me like pfSense is working properly. I would try disabling the firewall on the Windows VM and see if it's able to ping it's gateway.


  • Netgate Administrator

    Your port forward rules should almost certainly have 'WAN address' as the destination.

    Steve



  • Rebooted pfSense and the problem appears to have sorted itself out.  Now I just need to work on the port forwards and the fact I can't get connected to this server even via LAN.  Thanks guys.


  • Netgate Administrator

    If you are on LAN and trying to connect to the server using a URL (rather than an IP) you will need one of these solutions:
    https://doc.pfsense.org/index.php/Why_can't_I_access_forwarded_ports_on_my_WAN_IP_from_my_LAN/OPTx_networks

    Steve



  • I just had to adjust my port forwards/rules a bit.  Got everything sorted out.  I can connect on LAN and friends can connect over the internet.  8)


  • Netgate Administrator

    Win!  ;D

    Steve


Log in to reply