Squid install not working



  • Hello,

    I have pfsense 1.2.3 installed with nanoBSD and i've been trying to install squid and squidguard for a while.

    however, when i try to install a package i keep getting the following error

    Fatal error: Call to undefined function: squid_install_command() in /etc/inc/pkg-utils.inc(520) : eval()'d code on line 1

    php version 4.4.9

    Thanks


  • Rebel Alliance Developer Netgate

    1.2.3 is no longer supported. Squid+SquidGuard on NanoBSD on 1.2.3 even less so.

    There could be some remnant of a past installation somewhere on the drive in /usr/local/pkg/ or in the config.xml that needs cleaned out. Not enough info to say, but you should really be running the latest version (2.1.x) and not 1.2.x.


Log in to reply