[resolved] Possible bug? DHCP Server not assigning IP addresses on second LAN un



  • After typing a long post with my system setup and everything I'd tried, I realized I had not done a reboot since changing the configuration, and low and behold, that solved my issue. Perhaps someone can add this to the Multi-LAN Setup article.

    I had originally configured my second LAN port as OPT1, then later changed the name to LAN2 (and LAN to LAN1, though that still functioned as expected) and I could not get anything on LAN2 to be recognized by the DHCP server, despite everything appearing to be set up properly. I noticed that on some of the configuration pages (including Interfaces: Assign network ports) the name of LAN2 was still OPT1. After reboot, the port is called LAN2 everywhere I can find any listing of the ports by name.



  • Reboots aren't required for interface changes. I do that on the fly in production on customer systems probably a dozen times in an average week.

    After changing an interface name, its listing under Interface in the assignments tab is updated accordingly. That part even happens without applying the changes on the interface (applying its IP config does not). It's not possible to save an interface name change and have it not appear as changed under the assignments tab. If something happened to cause that, a reboot wouldn't fix it as that would mean the interface name wasn't saved at all.

    Not getting DHCP, my best guess is a save of the interface, but not applying the changes, so the interface didn't have an IP (or its former IP if re-assigned). Hence the DHCP server couldn't start. If you have DHCP server logs going back far enough, they might be telling on that portion. That's the only scenario I can think of where a reboot would make any difference.



  • Thanks. In moving the installation to a new box, I found that everything worked as you described. However, before rebooting I had carefully gone through to find if there were any changes waiting to be saved, and I tried making the changes again and saving them, but it wasn't acknowledging the change. I wonder if I paged back without saving, made some change, and somehow corrupted a record or something? Anyway, in the grand scheme of things, I'd rather devs work on improving 802.11n support than anything else.


Log in to reply