Enable Webconfigurator access via WAN with only one interface



  • Hello everyone,

    I have a virtual Server with only one WAN interface and no LAN interafaces.
    The WAN interface has a public IP adress.
    Pfsense is installed and the WAN interface is configured via shell but the webconfigurator is not reachable via HTTP and my public ip adress.

    How can I setup my pfsense box via shell to enable webconfigurator from my WAN interface?

    Thank you!


  • Netgate Administrator

    With only one interface configured the webgui should be accessible on WAN by default. You definitely have only one interface configured?
    Have you tried using https?

    Steve



  • Hi StephenW10,

    thank you for your answer. I've got this working with the help of this forum entry:
    https://forum.pfsense.org/index.php?topic=23543.0

    • Install pfSense  on your target machine

    • Unless your WAN gets a DHCP address, you will need to manually assign the IP Address of the WAN interface:
        –> Get to the CLI (option 8 )
        --> Type "ifconfig en0 10.20.30.40 255.255.255.248" (substitute en0 for your WAN interface and use the correct IP Address/Mask)
        --> Type "route add default <default-gw-ip>"
        --> Type "pfctl -d" to temporarily disable the packet filter</default-gw-ip>


  • Netgate Administrator

    Strange that you had to do that.  :-
    With only one interface assigned you should have access on that by default. As soon as you assign a second interface, LAN, that becomes the default way of accessing the webgui and WAN is blocked. That applies even if the LAN is not connected.
    Glad you got up and running anyway.  :)

    Steve


Log in to reply