Looping Squid Auth



  • Hello.
    After 3 days of tries and search, I finally post a thread to find some help here…
    I have a Squid / Squidguard that works perfectly since a couple of weeks.
    Now I'm trying to add a captive portal with the Squid Auth Settings.

    First I tried a local database with some users, it's ok. But I've got 1500+ users inside a Win2012R2 AD, then I tried both "NT Domain" and "LDAP" auth.

    Not sure if I have something to configure inside windows part... but I tried Squid with these settings :

    LDAP version 3
    server : ipadress
    port : 389
    LDAP server user DN : cn=ldap,cn=users,dc=xx,dc=yy
    LDAP password : xxxxxx
    LDAP base domain : dc=xx,dc=yy
    LDAP username DN attribute : uid
    LDAP search filter : sAMAccountName=%s

    I tried with NT domain settings :
    server : ipadress
    NT domain : xx.yy
    secondary NT servers : ipadress2

    In both case, the captive portal keeps looping asking my credentials...

    Any help please ?



  • No one to help a bit ? :(



  • Anything? Stuck on the same problem…

    I'll try to use squid3, maybe it works


Log in to reply