WAN nic not getting address from cable modem



  • So, I had a great setup and everything was working well.  Then I decided to tidy up my cables….now I can't get my WAN nic to grab an IP (DHCP) address from my cable modem.  If I plug the cable modem into a wireless router, the wireless router gets an address no problem.  But my pfsense computer can't seem to pick up an address.

    Here's my network topology.
    Cable modem --> switch --> 2 segments (1 through pfsense the other not)
    On the pfsense network, I've tried
    Cable modem --> to pfsense computer
    Cable modem --> switch --> pfsense computer

    I've also tried re seating the nic and changing nics and running the live cd version.

    Any suggestions would be appreciated.



  • Hi,

    So, a PPPOE connection with your 'old' router worked and it out just fine, but pfSense won't make the connection anymore.

    Just to be sure that all is ok, hook you cable modemn directly to your PC (Windows !), and use the Wizard to setup a PPPOE connection with you PC. It should work also.

    Put it back on the WAN NIC (the one you assigned as WAN !)
    Then check the menu pfSense => Interfaces => WAN
    The NIC is present ? The setup ok ?

    All I an say right know that your are close to a hardware problem. Moving cables around shouldn't influence your connection.
    Something else changed also …



  • It's a cable modem so PPPoE may not come into the picture.

    Jeremy, is your "cable modem" just a modem, modem/router in bridge mode or full modem/router?

    Have you tried switching off your modem for a while?  My cable ISP will only hand out a maximum of two IP addresses to a given modem.  Switching off and on gets around that.



  • Hummmm. You're right.
    Donno why I had PPPOE in mind …...


  • Netgate Administrator

    @JeremySchubert:

    ..everything was working well.  Then I decided to tidy up my cables….

    Classic 'if it aint broken' problem.  ;)
    What exactly did you change whebn you did this. Does the WAN show the link as UP? Do you have link LEDs on the hardware involved. It seems very likely that you introduced a fault when you re-arranged the WAN connection. That could be in the form of a bad cable or a switch that has issues etc.

    Steve



  • Thanks all for the help.  Killing the power to everything for a few hours did the trick.



  • Glad it's working.

    I've run into different scenarios with cable circuits.

    1)  Reboot cable modem and all is good.

    2)  If i've plugged in a laptop to test, the cable service locks in that mac address.  (probably just arp)  This can last up to a couple of hours.  Quick way around this is to spoof the laptop mac address in the pfsense interface or just wait it out and the circuit will eventually just come up.

    3)  Some cable providers lock the mac address in permanently and you have to call them to release it and give them your new mac address, or spoof as in #2.


Log in to reply