PPPOE : not obtaining an IP-address



  • Hello,
    I am doing my first install of Pfsense.  After the router BBOX2 of my ISP (Belgacom : Belgium) II have a Pfsense-PC.

    Wan (vx0)  is PPOE : I have entered my account from my ISP and password and for IPv6 no IP-address.
    My LAN (xl0) is at 192.168.3.1/24.  Both LAN and WAN are marked up in the dashboard.
    In the LAN there is the  IP-address : 192.168.3.1 of the Pfsense and is shown as 100baseTx <full-duplex>.

    In the System log : "Could not find IPv4 gateway for interface (wan)

    The firewall rules : I have started with "block all"-rules  individually for IPv4 and IPv6 any protocoll at the bottom
    Then building up the rules from the top by allowing the blocked items (show in the Firewall log).

    Is there anybody who has any suggestions?

    Thanks in advance and Kind regards
    Luc</full-duplex>



  • Have you set the BBox into bridge mode?  If not, this might help.



  • Hello biggsy,

    Thanks for your reply.
    The BBOX2 has the ability to pppoe-pass-through and it is in that way I am using the box.  In fact you don't have to alter any setting of the BBOX2.
    The BBOX2 has it own public IP-address and the router you place behind the BBOX2 is obtaining an other public IP-address.
    But my WAN side link is showing up but with no IP-address; i think it might have something to do with my firewallrules.
    In fact I am adding rules by allowing blockked  items from the firewall log, but afterwards the still are appearing in the firewall log as blocked.
    Probbally I am doing something wrong but I don't know what.

    Kind regards
    Luc



  • You really shouldn't need any firewall rules on WAN in order to use PPPoE.

    You could try unchecking Block private networks under Interfaces > WAN but I really have no idea if that's necessary.  Maybe someone else knows for sure.



  • Remove ALL Allow firewall rules on the WAN interface, right now! ;) Pretty dangerous!

    What have you entered on the

    Interfaces -> WAN

    page of the pfSense GUI?

    IPv4 connection type set to "PPPoE" in the drop-down menu?

    Your log-incredentials inserted for your provider under "username" and "password"?



  • I have deleted all firewall allow rules on the WAN.

    Like you (Chemlud) said under interface -> WAN  i have entered PPPOE for IPv4 and DHCP6 for IPv6
    and my login credentials from my provider : "fa5…....@skynet" and "password"

    I have also unchecked BLock private networks  under Wan interface.

    Still in system log Could not find IPv4 gateway for interface (wan) and now also for IPv6 like I have set it to DHCP6 for IPv6 unter interfaces -> WAN


  • Netgate Administrator

    Check the PPP logs.

    Steve



  • In my syslog successfull PPPoE looks like this

    Jun 16 04:02:08 >domain< ppp: [wan] Bundle: Interface ng0 created
    Jun 16 04:02:08 >domain< ppp: [wan_link0] Link: OPEN event
    Jun 16 04:02:08 >domain< kernel: ng0: changing name to 'pppoe0'
    Jun 16 04:02:08 >domain< ppp: [wan_link0] LCP: Open event
    Jun 16 04:02:08 >domain< ppp: [wan_link0] LCP: state change Initial –> Starting
    Jun 16 04:02:08 >domain< ppp: [wan_link0] LCP: LayerStart
    Jun 16 04:02:08 >domain< ppp: [wan_link0] PPPoE: Connecting to ''
    Jun 16 04:02:08 >domain< ppp: PPPoE: rec'd ACNAME "xxx-yyy-zzz"
    Jun 16 04:02:08 >domain< ppp: [wan_link0] PPPoE: connection successful



  • I started all over again by reinstalling Pfsense with all your advices and now its working.

    Thanks for all the advice

    Luc


Log in to reply