Routing between wan and lan



  • Hello guys,

    Amazing with pfSense ;) and am new to that and like it pretty well and am glad that people helped solved my other problems and now I have other question for routing

    basic home setup
    modem<->wan<->pfsense<->lan<->switch<->my pc, other pcs, wireless, etc

    my modem is on bridge mode on 192.168.254.254 and my pfsense gateway to lan is on 192.168.0.1

    I would like to remote to my modem to check adsl status for speed (from web) so how can I do it?, guide me for step to step to set up routing between lan and wan

    Thanks and cheers



  • Anyone?


  • Rebel Alliance



  • Thanks but unfortunately I can not get it to work, did tried several times but no idea why? can you have a look and tell what I have done wrong? I'm using latest pfSense 2.1.3

    Network on 192.168.0.xxx

    Modem on 192.168.254.254 (DHCP Server is enabled in modem setting) and pfSense can see and IP 192.168.254.1 on OPT1

    I would create IP 192.168.0.254 for remote to my modem

    Help me… thanks










  • also I did tried translation as well but didnt work




  • Take a harder look…  You didn't follow the directions.  :o  Only do what is under the 2.0 tab.  :)

    https://doc.pfsense.org/index.php/How_can_i_access_my_PPPoE_Modem_on_WAN#For_2.0

    For 2.0 Configure a new Interface On 2.0, a PPPoE WAN is actually assigned to a virtual PPPoE adapter, not the physical port. So the tricks above are not needed and the NAT portion will not work at all.
    If you already added the IP alias, remove it. If you added the IP alias via the shellcmd trick above, remove it also.
    Instead, under Interfaces > (assign), create a new OPT interface, and assign it to the physical network card that is on WAN. For example, if your WAN on the assignment page is "PPPOE0(fxp0)", choose fxp0, and Save your changes.
    Go to Interfaces > (your new OPT interface), and enable the interface. Give it an IP address in the same subnet as your modem, such as 192.168.1.5/24 (For example, the same IP address suggested in for the alias in the previous instructions). Do not set a gateway. If you like, you can rename the interface to something like ModemAccess.
    A_dd an Outbound NAT rule as described above but do NOT choose the WAN interface, choose your new OPT interface._
    You should then be able to access the modem from LAN.

    Your outbound nat is backwards…  Source is your LAN subnet.  Destination is your "ModemAccess"  static IP address.  ie  192.168.254.250/24  or whatever you use.  Dont use DHCP.



  • I did followed the instruction property but did not work so I tried different way (also sorry if i took snapshot when I tried that different way), found out that my firewall pfsense set to https for security reason so switched to http and reboot pfsense and after that it work so i switched back to https and all go okay now…. must be a little bug or server pfsense didnt reboot for more than 2 weeks

    Thanks and cheers


Log in to reply