[resolved] apcupsd daemon won't start



  • I've got an APC Back-UPS ES350 connected to my motherboard's only serial port, and when I start the daemon from the Status: Services page, I get this in the logs:

    Jun 14 08:00:00 	apcupsd[5556]: apcupsd FATAL ERROR in dumbsetup.c at line 65 Cannot open UPS port : No such file or directory
    Jun 14 08:00:00 	apcupsd[5556]: apcupsd error shutdown completed
    

    In Services: Apcupsd I have:

    Enable                    checked
    UPS cable                simple
    UPS Type / Device  dumb /dev/ttyu0

    I just migrated pfSense to this motherboard from my test rig, which was running apcupsd and giving me the UPS information with the same settings (except for device location). The serial port on this motherboard was working perfectly with a Smart UPS and apcupsd in Ubuntu before I installed pfSense to it, so the hardware should all be functioning properly.

    Any help appreciated!



  • I just finally solved this by using a USB cable. The serial cable had worked fine in with my other board and Ubuntu on this board, but for whatever reason, with pfSense on this board I can only get apcupsd to work with the USB cable.


Log in to reply