SIP Blocking



  • Hi Community, I have a PABX behind a PFsense box.
    The PABX has been using outbound SIP for some time without an issue.
    However we have pointed a few numbers to the PABX and can only sustain a 30 second conversation.

    I have plugged the PBX direct into the internet and put a public IP on it and it works fine in and out. So I put it down to something blocking it.

    I have added some Routes in the NAT for the RTP ports it needs and pointed them to the internal NAT but to no avail.

    Anyone have any suggestions on troubleshooting or what to change to make this puppy work?

    Thanks Graham



  • If the Pabx is Asterisk based, set NAT=yes and IP=public (even if the Pabx does not have a public ip address) in the configuration file.

    These settings usually solve the 30 seconds problem on incoming calls.



  • The PBX is a Panasonic NCP1000

    I have set the option of NAT on it and its public IP as well.

    It still fails after 30 Seconds, the SIP trace shows it hanging up the Call, so I would assume the Firewall is blocking packets that allow the registration.



  • Ok so looks like I solved the Mystery.

    It has to do with the Firewall but more so the PABX actually giving up getting communications going between A + B.

    The Panasonic is sending an request on an RTCP and getting no response. So like any good system it sends a goodbye command and hangs up.

    Luckily there's an option to disable this ability. Turned it off and walla it works a treat.


Log in to reply