Unable to upgrade



  • Hi,

    I'm trying to upgrade to 2.2-alpha to be able to test if I can get more speed from my 4G LTE connection (see: https://forum.pfsense.org/index.php?topic=78304.0), but both upgrade and clean install fails.

    I did few hours ago "upgrade from console" just to see if anything happens. First of all my machine failed to reboot after upgrade, it had to power cycle it. And now it's stuck on "Loading configuration….Done, Updating configuration....."

    Clean install starts ok, but after I restore my config from 2.1.3 it gets stuck on "Configuring users...." (or something like that).

    Archtecture is i386 and I didn't change it during update.


  • Rebel Alliance Developer Netgate

    Can you try again with a current snapshot and give more info about exactly where it stops?



  • Latest alpha says (console update)

    Upgrading firmware
    ........................................... Done. Rebooting.
    *** Welcome to pfSense 2.2-ALPHA-pfSense (i386) on firewall ***
    sockstat: struct xtcpcb size mismatch
    sockstat: struct xinpcb size mismatch
    

    And then upgrade shows the main menu.  (No reboot)

    Selecting number 5 (reboot system):

    Stopping package OpenVPN Client Export Utility...Done
    Stopping package nmap...Done
    Cannot create /dev/null: operation not supported. 
    *** Welcome to pfsense 2.2-alpha (etc)
    Sockstat: struct xtcpcb size mismatch
    sockstat: struct xinpcb size mismatch
    
    

    (No reboot)

    After power cycle booting gets stuck to

    Loading configuration....Done
    Updating configuration....
    
    

  • Rebel Alliance Developer Netgate

    It looks like maybe somehow your kernel does not match the installed world.

    What sort of hardware is this? And how was it originally installed? Full install from CD? NanoBSD? Did you order it from somewhere pre-installed?



  • Hardware is IBM ThinkPad T43 (2668-45G) with an additional pc-card nic (rl).

    Originally full install with pfSense 2.something, latest upgrade was tried when 2.1.3 was reinstalled from CD.



  • Here's a screen recording about what happens when I try to upgrade my testbed from 2.1.4 to 2.2. It doesn't reboot either after upgrade  but does boot after power cycle (even though no packages are (re-)installed).

    https://dl.dropboxusercontent.com/u/281722/pfSense.mov



  • Latest snapshot does reboot after install and also reinstalls all packages.

    2.2-ALPHA (i386)
    built on Fri Jul 11 06:23:43 CDT 2014
    FreeBSD 10.0-STABLE