Not restarting after upgrade



  • After upgrading from 2.1.3 to the latest 2.2 alpha, system didn't restart after the process done. Had to physically pull the plug after multiple attempts using the reboot option in the web gui. Dashboard said that it was on the 2.2 alpha and all of the packages/services had a red X next to them but pfsense was still functioning.

    To verify, I tried upgrading another system with slightly different hardware and had the same result.

    Using reboot from the gui does work after physically pulling the plug to restart the system.



  • Not seeing the same thing just upgrading between snapshots.  Did your second system you tried also have packages installed?

    2.2-ALPHA (amd64)
    built on Fri Jun 20 07:36:50 CDT 2014



  • Happens to me. After upgrade from 17(?) to Jun 20 07:36:50 the box do not reboot. I have suricata installed.

    2.2-ALPHA (amd64)
    built on Fri Jun 20 07:36:50 CDT 2014
    FreeBSD 10.0-STABLE
    Full version installed on a USB.



  • Not seeing it here, after updating from (about) 20-May alpha to 20-June alpha.  x86-64, physical machines, no packages.  Also cannot reproduce it with i386 or x86-64 virtual box machines.

    When it hangs, is there anything interesting in the logs or on the console?  What about the last few lines of /cf/conf/upgrade_log.txt?  Mine typically look like so:

    .
    .
    .
    local/livefs/lib: 
            modification time (Tue May 20 15:58:13 2014, Fri Jun 20 09:10:24 2014)
    Checking for /tmp//tmp/post_upgrade_command.php... 
    Running /tmp/post_upgrade_command.php 
    Adding serial port settings ()...
    Reading /boot/loader.conf...
    Fri Jun 20 12:23:20 EDT 2014
    
    Firmware upgrade is complete. Rebooting in 10 seconds.
    
    

Log in to reply