Watchguard x750e - msk drivers

  • Hello All,

    First just wanted to say I don't know too hell of alot about pfsense but i did manage to get it up and running on the Watchguard x750e.

    So my question is, I've tried to google some of the issues concerning the msk0 timeout of the drivers but there is so much information that i can't fit it all into comprehensive steps.

    Could anyone please help me with this issue?

    Much Appreciated!

  • Thank you.

    My next question is how should i add specific lines of commands in, for example "/boot/loader.conf.local."

    Would i be correct in saying that i could use a program like WiinSCP? Or is there a better way?

    In addition to the steps that are outlined on should i be adding anything else? Or am i completely done after adding these commands to stop the ports from timing out?

    Thanks for the help, and i apologize i wasn't able to find this page before. I can assure you i spent hours on other forums as well as this one just scratching my head before i posted. Sorry for newbing out!

  • Netgate Administrator

    Adding that line to disable msi in the msk driver should be sufficient to prevent timeouts.
    You can change the driver to get the expected LED behaviour if you want. That's also detailed in the docs page.


  • Steve,

    Thanks for your reply. I just wanted to ask, yet another question.

    I've notice that the 12 hour port timeouts are not happening now after I've added the commands. However, now every 2 days, depending on my traffic, i'll have to restart my firewall again, just like i did with the 12 hour timeouts.

    Any reason to this?

  • Netgate Administrator

    Nope, you shouldn't have to restart it ever (within reason!)  ;)

    What are the symptoms? Anything in the logs? (if you can reach them)

    What sort of traffic levels/types are you putting through the box? A common cause of the box stopping routing is running out of space in the routing table or some other state exhaustion. That can often be caused by torrent traffic or similar high connection numbers.

    Which interfaces are you using? I've never seen a problem after adding that one line to /boot/loader.conf.local but some other users have recommended disabling MSI globally. I've not seen any evidence that that helps and it removes the ability of anything alse to use it robbing the system of interrupts.


Log in to reply