HELP! ON SWAP



  • I was facing frequent crashes of squid on my pfsense 2.1 amd64 on E2180 2.0Ghz, G31 Intel motherboard, 2GBddr2, 80GB hdd with squid 3.3.10 v2.2.2 & qlproxy 3.2 installed, On reboot the memory utilization on the gui shows 27% it increases to 53% the next day, 89% on the third day, 93% on the 4th day and then in would start receiving ICAP protocol errors, restarting squid and qlproxy did not resolve the problem, I had to reboot the firewall for it to start, the phenomenon occurred 3 times. Suddenly I realized that SWAP memory was not shown in the gui, So I started it usingswapon /dev/ad4s1b  I could see 2048mb swap memory available in the GUI, but after a reboot the SWAP memory was not visible in the GUI, I again started it from the cli using```
    swapon /dev/ad4s1b

    How do I permenantly make SWAP available?
    gpart shows ad4 my 74G disk with 70G partition, but when I enable swap it shows only 2048Mb, How do I make it 4096Mb?
    
    cirkit


  • I'm assuming this is a full install and not nano. Putting aside the issue of a possible memory leak, you generally make swap permanent by adding it to /etc/fstab. Something like:
    #/dev/label/swap0              none            swap    sw              0      0

    Ref. https://www.freebsd.org/doc/handbook/adding-swap-space.html

    To increase the size of the swap you will need to repartition the disk or create a "swap file" (see link above) and add it to fstab as above.

    But… I don't think that's the problem. You should not be running out of RAM (and IMHO not even swapping at all). Other than the ICAP errors, what are you seeing that leads you to suspect the memory? Are there memory related errors in Status: System logs: General?  (i.e. out of swap space, memory exhausted, unable to create, etc.) In your situation,  I'd recommend looking for the source of the ICAP errors first.


Log in to reply